net-firewall/nftables: rename modern_kernel use flag
authorFrancisco Blas (klondike) Izquierdo Riera <klondike@gentoo.org>
Tue, 3 Dec 2019 00:39:53 +0000 (01:39 +0100)
committerMatthew Thode <prometheanfire@gentoo.org>
Tue, 3 Dec 2019 16:10:20 +0000 (10:10 -0600)
When the new scripts supporting atomic updates on modern kernels
where introduced, usage of the new scripts was controlled by the
modern_kernel USE flag.

QA has requested that we avoid using underscores on USE flags as
they are a reserved character.

Rename the modern_kernel USE flag to modern-kernel to address
this issue.

Closes: https://bugs.gentoo.org/694838
Signed-off-by: Francisco Blas Izquierdo Riera (klondike) <klondike@gentoo.org>
Package-Manager: Portage-2.3.76, Repoman-2.3.11
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
net-firewall/nftables/metadata.xml
net-firewall/nftables/nftables-0.9.0-r5.ebuild
net-firewall/nftables/nftables-0.9.1-r1.ebuild
net-firewall/nftables/nftables-0.9.2-r1.ebuild

index 0984d13e0f036d62963cbfa5bac27af2c5963fa1..0380331d5106dc0b46c2cd11744503c5ccc10d04 100644 (file)
@@ -16,7 +16,7 @@
        <use>
                <flag name="doc">Create man pages for the package (requires <pkg>app-text/asciidoc</pkg>)</flag>
                <flag name="json">Enable JSON support via <pkg>dev-libs/jansson</pkg></flag>
-               <flag name="modern_kernel">Install init scripts for 3.18 or higher kernels with atomic rule updates</flag>
+               <flag name="modern-kernel">Install init scripts for 3.18 or higher kernels with atomic rule updates</flag>
                <flag name="xtables">Add libxtables support to try to automatically translate rules added by iptables-compat</flag>
        </use>
 </pkgmetadata>
index 2ad8c89d4c73c340195e551da413466a76e41e79..dc29d33b649ee8058d0778b5bd1d199fc264233c 100644 (file)
@@ -12,7 +12,7 @@ SRC_URI="https://git.netfilter.org/nftables/snapshot/v${PV}.tar.gz -> ${P}.tar.g
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="amd64 arm ~arm64 ia64 x86"
-IUSE="debug doc +gmp json +modern_kernel +readline"
+IUSE="debug doc +gmp json +modern-kernel +readline"
 
 RDEPEND=">=net-libs/libmnl-1.0.3:0=
        gmp? ( dev-libs/gmp:0= )
@@ -31,8 +31,8 @@ S="${WORKDIR}/v${PV}"
 
 pkg_setup() {
        if kernel_is ge 3 13; then
-               if use modern_kernel && kernel_is lt 3 18; then
-                       eerror "The modern_kernel USE flag requires kernel version 3.18 or newer to work properly."
+               if use modern-kernel && kernel_is lt 3 18; then
+                       eerror "The modern-kernel USE flag requires kernel version 3.18 or newer to work properly."
                fi
                CONFIG_CHECK="~NF_TABLES"
                linux-info_pkg_setup
@@ -62,7 +62,7 @@ src_install() {
        default
 
        local mksuffix=""
-       use modern_kernel && mksuffix="-mk"
+       use modern-kernel && mksuffix="-mk"
 
        exeinto /usr/libexec/${PN}
        newexe "${FILESDIR}"/libexec/${PN}${mksuffix}.sh ${PN}.sh
index ef662d78f71675352ed236a97a74f337a5145608..8538c51884d684e7f1a040ef0a38b02e818c0f94 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~x86"
-IUSE="debug +doc +gmp json +modern_kernel python +readline static-libs xtables"
+IUSE="debug +doc +gmp json +modern-kernel python +readline static-libs xtables"
 
 RDEPEND="
        >=net-libs/libmnl-1.0.3:0=
@@ -57,8 +57,8 @@ python_make() {
 
 pkg_setup() {
        if kernel_is ge 3 13; then
-               if use modern_kernel && kernel_is lt 3 18; then
-                       eerror "The modern_kernel USE flag requires kernel version 3.18 or newer to work properly."
+               if use modern-kernel && kernel_is lt 3 18; then
+                       eerror "The modern-kernel USE flag requires kernel version 3.18 or newer to work properly."
                fi
                CONFIG_CHECK="~NF_TABLES"
                linux-info_pkg_setup
@@ -106,7 +106,7 @@ src_compile() {
 src_install() {
        default
 
-       local mksuffix="$(usex modern_kernel '-mk' '')"
+       local mksuffix="$(usex modern-kernel '-mk' '')"
 
        exeinto /usr/libexec/${PN}
        newexe "${FILESDIR}"/libexec/${PN}${mksuffix}.sh ${PN}.sh
index f8649c46afaf41f843acf035d28a70c71e69268f..5dd8147c26d4a15237468db06f4a655af305c7ed 100644 (file)
@@ -15,7 +15,7 @@ SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2"
 LICENSE="GPL-2"
 SLOT="0"
 KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~sparc ~x86"
-IUSE="debug +doc +gmp json +modern_kernel python +readline static-libs xtables"
+IUSE="debug +doc +gmp json +modern-kernel python +readline static-libs xtables"
 
 RDEPEND="
        >=net-libs/libmnl-1.0.3:0=
@@ -52,8 +52,8 @@ python_make() {
 
 pkg_setup() {
        if kernel_is ge 3 13; then
-               if use modern_kernel && kernel_is lt 3 18; then
-                       eerror "The modern_kernel USE flag requires kernel version 3.18 or newer to work properly."
+               if use modern-kernel && kernel_is lt 3 18; then
+                       eerror "The modern-kernel USE flag requires kernel version 3.18 or newer to work properly."
                fi
                CONFIG_CHECK="~NF_TABLES"
                linux-info_pkg_setup
@@ -101,7 +101,7 @@ src_compile() {
 src_install() {
        default
 
-       local mksuffix="$(usex modern_kernel '-mk' '')"
+       local mksuffix="$(usex modern-kernel '-mk' '')"
 
        exeinto /usr/libexec/${PN}
        newexe "${FILESDIR}"/libexec/${PN}${mksuffix}.sh ${PN}.sh