dev-python/pymad: version bump to 0.10, add py3 support, update metadata
authorWim Muskee <wimmuskee@gmail.com>
Sun, 8 Dec 2019 15:21:51 +0000 (16:21 +0100)
committerDavid Seifert <soap@gentoo.org>
Sun, 8 Dec 2019 15:21:51 +0000 (16:21 +0100)
Closes: https://bugs.gentoo.org/702120
Closes: https://github.com/gentoo/gentoo/pull/13915
Signed-off-by: Wim Muskee <wimmuskee@gmail.com>
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pymad/Manifest
dev-python/pymad/metadata.xml
dev-python/pymad/pymad-0.10.ebuild [new file with mode: 0644]

index 5e9db8c0899418b2ac69f6f04e7e76d0d5834fdc..d65626de3182d296ee0e96aa33490015cfa81edb 100644 (file)
@@ -1 +1,2 @@
+DIST pymad-0.10.tar.gz 26815 BLAKE2B df694f1fcc7b2c6d0d0aa064b60d061ade2240085867b6a12b3ed63a93cbcac20ac40b3929fbf5b8d9c7b6dbc52883130d02b309ce7690addda6c78813ca2847 SHA512 68a7c93031d174ab50dfa406eec4166be2158d39c4231baee18b7d9c879692376cbf491bcd3e5747e65c496b07a40d1597532551aedcdf05d0fa46f6e185a3d8
 DIST pymad-0.6.tar.gz 22099 BLAKE2B d0d63114bc24fd94b0f4b1e0d58324cc625772035315cbb6f62bf496c8090db446966a689de08c079f9389295e8efedd885cba5c989d86c31e3291838eb75103 SHA512 1493925cf0fca3ede8314071795736354e2f036f41a9e72cfcf77f960c84bba8e76b43ce7c389c15dc9f2f619ce77b0afae1b78558b1617240bdde3012ad753c
index 9e5274c5b4ae2ec902611e9f9f1c981c5b4f112f..e24cb2a46b11054f629a15da3febb7154d9dea4a 100644 (file)
@@ -5,4 +5,7 @@
        <email>python@gentoo.org</email>
        <name>Python</name>
 </maintainer>
+<upstream>
+       <remote-id type="github">jaqx0r/pymad</remote-id>
+</upstream>
 </pkgmetadata>
diff --git a/dev-python/pymad/pymad-0.10.ebuild b/dev-python/pymad/pymad-0.10.ebuild
new file mode 100644 (file)
index 0000000..f05e37f
--- /dev/null
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="https://github.com/jaqx0r/pymad"
+SRC_URI="https://github.com/jaqx0r/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-version-${PV}"