x11-misc/macopix: Fix build when windres is not available (bug #610568).
authorJeroen Roovers <jer@gentoo.org>
Thu, 23 Feb 2017 20:00:41 +0000 (21:00 +0100)
committerJeroen Roovers <jer@gentoo.org>
Thu, 23 Feb 2017 20:01:05 +0000 (21:01 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

x11-misc/macopix/files/macopix-1.7.4-windres.patch [new file with mode: 0644]
x11-misc/macopix/macopix-1.7.4-r1.ebuild

diff --git a/x11-misc/macopix/files/macopix-1.7.4-windres.patch b/x11-misc/macopix/files/macopix-1.7.4-windres.patch
new file mode 100644 (file)
index 0000000..e26bf62
--- /dev/null
@@ -0,0 +1,58 @@
+--- a/configure.in
++++ b/configure.in
+@@ -145,26 +145,10 @@
+                           [use Gtk+1.2 insted of Gtk+2]),
+                           [use_gtk1=yes])
+-if test x"${use_gtk1}" = "xyes"; then
+-AM_PATH_GLIB(1.2.6,,
+-        AC_MSG_ERROR(Test for GLIB failed. See the file 'INSTALL' for help.),
+-        gthread)
+-AM_PATH_GTK(1.2.0, ,
+-            AC_MSG_ERROR(Cannot find GTK: Is gtk-config in path?))
+-AM_PATH_GDK_PIXBUF(0.7.0, ,
+-              AC_MSG_ERROR(Cannot find GdkPixbuf: Is gdk-pixbuf-config in path?))
+-dnl for libpng  (In the case of Gtk+2, gdk_pixbuf_save are used.)
+-AC_CHECK_LIB(png,png_create_write_struct,
+-        [PNGLIB_LIBS="-lz -lpng -lm"],
+-        [AC_MSG_ERROR(libpng is required.)],
+-      -lz -lm)
+-
+-else
+ AM_PATH_GLIB_2_0(2.0.0,, AC_MSG_ERROR([glib-2.x is required]), gthread gobject)
+ AM_PATH_GTK_2_0(2.0.0,, AC_MSG_ERROR([gtk+-2.x is required]), gthread gobject)
+ AC_DEFINE(USE_GTK2,[], [Use Gtk+2.x instead of Gtk+1.x])
+ PNGLIB_LIBS=""
+-fi
+ AC_SUBST(PNGLIB_LIBS)
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -9,14 +9,6 @@
+        bmp.h sockmsg.h codeconv.h unmime.h base64.h quoted-printable.h\
+          macopix_icon.h tar32api.h ssl.h
+-if HAVE_WINDRES
+-MACOPIX_RES = macopix.res
+-macopix.res: macopix_res.rc
+-      $(WINDRES) $< -O coff -o $@
+-else
+-MACOPIX_RES = 
+-endif
+-
+ EXTRA_DIST = \
+       macopix_res.rc.in\
+         macopix.ico\
+@@ -25,9 +17,9 @@
+       tar32.dll\
+       libtar32.a
+-INCLUDES        = @GTK_CFLAGS@  @GDK_PIXBUF_CFLAGS@ $(GNUTLS_CFLAGS)\
++INCLUDES        = @GTK_CFLAGS@ $(GNUTLS_CFLAGS)\
+                 $(DISABLE_DEPRECATED)
+-LDADD           = @GTK_LIBS@  @GDK_PIXBUF_LIBS@ $(PNGLIB_LIBS) $(WINMM_LIBS)\
++LDADD           = @GTK_LIBS@ $(PNGLIB_LIBS) $(WINMM_LIBS)\
+                    $(MACOPIX_RES)  $(WINSOCK_LIBS) $(UNLHA32_LIBS)  $(TAR32_LIBS) $(GNUTLS_LIBS) $(WIN32_ICONV_LIBS)
+ CLEANFILES      = *~
+ DISTCLEANFILES  = .deps/*.P
index 6392b64eefe57c1d71e23075e651106d67fb138e..2d8d819ea66ccc0a48b5194585d2c06c26bb292c 100644 (file)
@@ -3,7 +3,7 @@
 # $Id$
 
 EAPI=6
-inherit flag-o-matic
+inherit autotools flag-o-matic
 
 DESCRIPTION="MaCoPiX (Mascot Constructive Pilot for X) is a desktop mascot application"
 HOMEPAGE="http://rosegray.sakura.ne.jp/macopix/index-e.html"
@@ -27,7 +27,7 @@ MY_MASCOTS="
 "
 
 for i in ${MY_MASCOTS} ; do
-       SRC_URI="${SRC_URI} ${BASE_URI}/${i}.tar.gz"
+       SRC_URI+=" ${BASE_URI}/${i}.tar.gz"
 done
 
 # programme itself is GPL-2, and mascots are free-noncomm
@@ -39,8 +39,8 @@ IUSE="gnutls nls"
 RDEPEND="
        dev-libs/glib:2
        media-libs/libpng:0=
+       sys-devel/gettext
        x11-libs/gtk+:2
-       nls? ( >=sys-devel/gettext-0.10 )
        gnutls? ( net-libs/gnutls )
        !gnutls? ( dev-libs/openssl:0= )
 "
@@ -48,20 +48,20 @@ DEPEND="
        ${RDEPEND}
        virtual/pkgconfig
 "
+PATCHES=(
+       "${FILESDIR}"/${P}-windres.patch
+)
 
 src_prepare() {
        default
 
-       sed -i -e 's|HAVE_WINDRES_TRUE|HAVE_WINDRES_FALSE|g' src/Makefile.in || die
-
-       append-libs -lX11
+       eautoreconf
 }
 
 src_configure() {
-       econf \
-               --with-gtk2 \
-               $(use_enable nls) \
-               $(use_with gnutls)
+       append-libs -lX11
+
+       econf $(use_with gnutls)
 }
 
 src_install() {