net-libs/rpcsvc-proto: revert "drop old"
authorSergei Trofimovich <slyfox@gentoo.org>
Tue, 24 Mar 2020 07:07:46 +0000 (07:07 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Tue, 24 Mar 2020 07:07:46 +0000 (07:07 +0000)
This reverts commit 0fce167fe7807642cf1249861be0b711506e80d6.

Dropped latest ebuild by accident.

Reported-by: Mr_Bones_
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild [new file with mode: 0644]

diff --git a/net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild b/net-libs/rpcsvc-proto/rpcsvc-proto-1.4-r1.ebuild
new file mode 100644 (file)
index 0000000..bea100d
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="rpcsvc protocol definitions from glibc"
+HOMEPAGE="https://github.com/thkukuk/rpcsvc-proto"
+SRC_URI="https://github.com/thkukuk/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="LGPL-2.1+ BSD"
+KEYWORDS="~alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
+IUSE=""
+
+# sys-devel/gettext is only for libintl detection macros.
+DEPEND="sys-devel/gettext"
+RDEPEND="
+       !<sys-libs/glibc-2.26
+       virtual/libintl
+"
+
+PATCHES=("${FILESDIR}"/${P}-external-libintl.patch)
+
+src_prepare() {
+       default
+       eautoreconf
+}
+
+src_install() {
+       default
+
+       # provided by sys-fs/quota[rpc]
+       rm "${ED}"/usr/include/rpcsvc/rquota.{x,h} || die
+}