removed old versions. Fixed locking problem as per bug #154969 Thanks Donnie + Bastia...
authorDaniel Black <dragonheart@gentoo.org>
Sat, 9 Dec 2006 03:02:29 +0000 (03:02 +0000)
committerDaniel Black <dragonheart@gentoo.org>
Sat, 9 Dec 2006 03:02:29 +0000 (03:02 +0000)
Package-Manager: portage-2.1.2_rc2-r5

dev-python/pycurl/ChangeLog
dev-python/pycurl/files/digest-pycurl-7.15.4.2-r1 [new file with mode: 0644]
dev-python/pycurl/files/digest-pycurl-7.15.5.1 [new file with mode: 0644]
dev-python/pycurl/files/pycurl-7.15.4.2-locking.patch [new file with mode: 0644]
dev-python/pycurl/pycurl-7.15.1.ebuild
dev-python/pycurl/pycurl-7.15.4.2-r1.ebuild [new file with mode: 0644]
dev-python/pycurl/pycurl-7.15.5.1.ebuild [new file with mode: 0644]

index ce6b4be0872de760f0529e9c0c5daab895709f63..1024d628f12e308db3752527739983aebc1330da 100644 (file)
@@ -1,6 +1,17 @@
 # ChangeLog for dev-python/pycurl
 # Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/ChangeLog,v 1.35 2006/12/08 22:35:27 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/ChangeLog,v 1.36 2006/12/09 03:02:29 dragonheart Exp $
+
+*pycurl-7.15.5.1 (09 Dec 2006)
+*pycurl-7.15.4.2-r1 (09 Dec 2006)
+
+  09 Dec 2006; Daniel Black <dragonheart@gentoo.org>
+  +files/pycurl-7.15.4.2-locking.patch, -pycurl-7.13.1.ebuild,
+  pycurl-7.15.1.ebuild, -pycurl-7.15.2.ebuild, -pycurl-7.15.4.2.ebuild,
+  +pycurl-7.15.4.2-r1.ebuild, +pycurl-7.15.5.1.ebuild:
+  removed old version. Fixed locking problem as per bug #154969 Thanks Donnie
+  + Bastian Kleineidam (debian bug #380156). Note all versions fail against
+  curl-7.16.0 - reported upstream on sf
 
   08 Dec 2006; Timothy Redaelli <drizzt@gentoo.org> pycurl-7.15.4.2.ebuild:
   Add ~x86-fbsd keyword
diff --git a/dev-python/pycurl/files/digest-pycurl-7.15.4.2-r1 b/dev-python/pycurl/files/digest-pycurl-7.15.4.2-r1
new file mode 100644 (file)
index 0000000..a498762
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 623d755ec8b938d9f9de3caa24078c51 pycurl-7.15.4.2.tar.gz 65694
+RMD160 6842b30f22933cc6fc37021b748015bdcb9759ab pycurl-7.15.4.2.tar.gz 65694
+SHA256 bbbd407cb6877d52bebdcee78d323c19eb6db5efb1defaf777b3d695c2134263 pycurl-7.15.4.2.tar.gz 65694
diff --git a/dev-python/pycurl/files/digest-pycurl-7.15.5.1 b/dev-python/pycurl/files/digest-pycurl-7.15.5.1
new file mode 100644 (file)
index 0000000..61364b5
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 464cfbeba150d99d92a407c7c8b751de pycurl-7.15.5.1.tar.gz 66075
+RMD160 c40849ca6a670a64549d258f6cb8156be4fcf87c pycurl-7.15.5.1.tar.gz 66075
+SHA256 93a786476a32f88622ada3fe355a1cef136d9658b39ac76806ef4ba154bbd2f9 pycurl-7.15.5.1.tar.gz 66075
diff --git a/dev-python/pycurl/files/pycurl-7.15.4.2-locking.patch b/dev-python/pycurl/files/pycurl-7.15.4.2-locking.patch
new file mode 100644 (file)
index 0000000..0fb6be6
--- /dev/null
@@ -0,0 +1,11 @@
+--- pycurl.c_  2006-08-07 20:28:46.694127911 +0200
++++ pycurl.c   2006-08-07 20:28:56.333679645 +0200
+@@ -416,7 +416,7 @@
+ static int pycurl_ssl_mutex_lock(void **m)
+ {
+-    return PyThread_acquire_lock(*((PyThread_type_lock *) m), 1);
++    return !PyThread_acquire_lock(*((PyThread_type_lock *) m), 1);
+ }
+ static int pycurl_ssl_mutex_unlock(void **m)
index b8d09002d540aa0705ae0bc44736e2ef0199b7fb..6c71e082b172a4b333c5a6d431163b1060f6013a 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.15.1.ebuild,v 1.5 2006/07/23 01:10:34 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.15.1.ebuild,v 1.6 2006/12/09 03:02:29 dragonheart Exp $
 
 inherit distutils
 
@@ -14,7 +14,8 @@ KEYWORDS="amd64 ppc ppc64 ~sparc x86"
 IUSE=""
 
 DEPEND="virtual/python
-       >=net-misc/curl-${PV}"
+       >=net-misc/curl-${PV}
+       <net-misc/curl-7.16.0"
 
 PYTHON_MODNAME="curl"
 
diff --git a/dev-python/pycurl/pycurl-7.15.4.2-r1.ebuild b/dev-python/pycurl/pycurl-7.15.4.2-r1.ebuild
new file mode 100644 (file)
index 0000000..f1ad41b
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.15.4.2-r1.ebuild,v 1.1 2006/12/09 03:02:29 dragonheart Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="http://pycurl.sourceforge.net/"
+SRC_URI="http://pycurl.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/python
+       >=net-misc/curl-7.15.4
+       <net-misc/curl-7.16.0"
+
+PYTHON_MODNAME="curl"
+
+src_unpack() {
+       unpack "${A}"
+       cd "${S}"/src
+       epatch "${FILESDIR}"/${P}-locking.patch
+}
+
+src_install(){
+       DOCS="TODO"
+       distutils_src_install
+       mv ${D}/usr/share/doc/pycurl/examples ${D}/usr/share/doc/${PF}
+       mv ${D}/usr/share/doc/pycurl/html ${D}/usr/share/doc/${PF}
+       mv ${D}/usr/share/doc/pycurl/tests ${D}/usr/share/doc/${PF}
+       rm -fr ${D}/usr/share/doc/pycurl
+}
diff --git a/dev-python/pycurl/pycurl-7.15.5.1.ebuild b/dev-python/pycurl/pycurl-7.15.5.1.ebuild
new file mode 100644 (file)
index 0000000..24ce8fe
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycurl/pycurl-7.15.5.1.ebuild,v 1.1 2006/12/09 03:02:29 dragonheart Exp $
+
+inherit distutils
+
+DESCRIPTION="python binding for curl/libcurl"
+HOMEPAGE="http://pycurl.sourceforge.net/"
+SRC_URI="http://pycurl.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/python
+       >=net-misc/curl-7.15.4
+       <net-misc/curl-7.16.0"
+
+PYTHON_MODNAME="curl"
+
+src_install(){
+       DOCS="TODO"
+       distutils_src_install
+       mv ${D}/usr/share/doc/pycurl/examples ${D}/usr/share/doc/${PF}
+       mv ${D}/usr/share/doc/pycurl/html ${D}/usr/share/doc/${PF}
+       mv ${D}/usr/share/doc/pycurl/tests ${D}/usr/share/doc/${PF}
+       rm -fr ${D}/usr/share/doc/pycurl
+}