sys-cluster/torque: updated 4.2.10
authorIan Stakenvicius <axs@gentoo.org>
Mon, 25 Feb 2019 20:32:40 +0000 (15:32 -0500)
committerIan Stakenvicius <axs@gentoo.org>
Thu, 7 Mar 2019 17:37:39 +0000 (12:37 -0500)
Switched the distfile to a snapshot of the latest from 4.2.10 branch in
github, which includes a large number of changes and bug fixes.  Also
included a patch to address -fpermissive compilation errors sometimes
experienced with newer toolchains.

Signed-off-by: Ian Stakenvicius <axs@gentoo.org>
Package-Manager: Portage-2.3.49, Repoman-2.3.11

sys-cluster/torque/Manifest
sys-cluster/torque/files/torque-4.2-use-NULL-instead-of-char0.patch [new file with mode: 0644]
sys-cluster/torque/torque-4.2.10-r1.ebuild [moved from sys-cluster/torque/torque-4.2.10.ebuild with 93% similarity]

index 27f557e822df391af5e36ed9ac20a3e639b830e9..7b5ca3a6350adcd56b43332bb24c2f359ee9827e 100644 (file)
@@ -1,5 +1,5 @@
 DIST torque-2.5.13.tar.gz 5854910 BLAKE2B 47fa519cbd2d9aeecb3bc323ba3f08f871b2259eb9c83335449a1f7c0d382fdffd0ced4f3ef09707c50a222d77ca0e5a39536b5c0f734bee37d3b50aec710430 SHA512 e08ddf3950bb32177f4bc504a502fae3928a616739c28ca9687c5207606817d4589583306508a2c568cf19fc8c5617dc4a9decc81576c2875660b715c256cfcf
 DIST torque-4.1.7.tar.gz 6218108 BLAKE2B 6c1ad0f1bb3f364603ad7f498999bd910491910fa5632b9f6b82e08b3afb8c54e8775c38bc8e5c959aa99d0647c54c7c348cd07bcbe11add8bfab5f3f06a4c80 SHA512 5a085c0a7b205fed075bff4599db90ca5c4bb5f22d87d76fd56539d5cc1935bb8eeffcd4d18ba84401bd4ca128718070b69c8b91ab6814a4638622ba351654e6
-DIST torque-4.2.10.tar.gz 6294022 BLAKE2B 2a57bebd7d9160deb3c610c21e1014a813c6e53771aadd65241d5fc623d41dca314e7b391cb218e0c9e917936c0547d1ba4c184442c20cef8bb62f98072537cc SHA512 898703fa1d02310c22e2a02b86d67ca52ebed46684597931944edebb39f8293746739c8dca9cd10e07c2e7274c3dd7f65a5664d1980817e3feec58952c4cf4d1
+DIST torque-4.2.10-gh-20150517.tar.gz 5836286 BLAKE2B 7108f1adcb6f674526b7db97df4ebcee04ae5c818d4f35ed1230a4e72e52ec0bc3b44e17334a143b21bcd3acccefc3927eca4f98d54d37745c8bb46a75e07045 SHA512 600bb5389b6a4161732b7aa82627f1ebeae238d7091aa2e223d9a14c44bf4668662f664b976f62ba3f1d8a366f90fb6058a8c904e20c26432dccd6abcd9c57fa
 DIST torque-4.2.9.tar.gz 6294022 BLAKE2B 2a57bebd7d9160deb3c610c21e1014a813c6e53771aadd65241d5fc623d41dca314e7b391cb218e0c9e917936c0547d1ba4c184442c20cef8bb62f98072537cc SHA512 898703fa1d02310c22e2a02b86d67ca52ebed46684597931944edebb39f8293746739c8dca9cd10e07c2e7274c3dd7f65a5664d1980817e3feec58952c4cf4d1
 DIST torque-6.0.3-1485300822_19e79ad.tar.gz 41660338 BLAKE2B 5e6c2e4bfffbe96d3a3e441f4c4420b4cb81a882bc498c4bf9474cf15a6808234f444183876a5ccfd46b6a9e4113d404cf72359ab3166146c3040854485f807d SHA512 40531f2e7732a11ffc224c536f61adc48ce5699a7caebb8aa1fbe7536b5ca4ed66c8436420bc918f7538ef980818141888aa26390a5a2c8185c8cc57373a0ac1
diff --git a/sys-cluster/torque/files/torque-4.2-use-NULL-instead-of-char0.patch b/sys-cluster/torque/files/torque-4.2-use-NULL-instead-of-char0.patch
new file mode 100644 (file)
index 0000000..a1cb853
--- /dev/null
@@ -0,0 +1,140 @@
+--- a/src/cmds/pbsnodes.c      2015-03-17 16:43:36.000000000 -0400
++++ b/src/cmds/pbsnodes.c      2019-02-25 12:33:37.824638386 -0500
+@@ -693,7 +693,7 @@
+         /* -N n is the same as -N ""  -- it clears the note */
+         if (!strcmp(note, "n"))
+-          *note = '\0';
++          *note = NULL;
+         if (strlen(note) > MAX_NOTE)
+           {
+@@ -821,7 +821,7 @@
+         {
+         nodeargs = (char **)calloc(2, sizeof(char **));
+         nodeargs[0] = strdup("");
+-        nodeargs[1] = '\0';
++        nodeargs[1] = NULL;
+         }
+       }
+     }
+@@ -901,7 +901,7 @@
+         MXMLCreateE(&DE, "Data");
+-        for (lindex = 0;nodeargs[lindex] != '\0';lindex++)
++        for (lindex = 0;nodeargs[lindex] != NULL;lindex++)
+           {
+           bstatus = statnode(con, nodeargs[lindex]);
+@@ -922,7 +922,7 @@
+         }
+       else
+         {
+-        for (lindex = 0;nodeargs[lindex] != '\0';lindex++)
++        for (lindex = 0;nodeargs[lindex] != NULL;lindex++)
+           {
+           bstatus = statnode(con, nodeargs[lindex]);
+@@ -946,7 +946,7 @@
+       /* list any node that is DOWN, OFFLINE, or UNKNOWN */
+-      for (lindex = 0;nodeargs[lindex] != '\0';lindex++)
++      for (lindex = 0;nodeargs[lindex] != NULL;lindex++)
+         {
+         bstatus = statnode(con, nodeargs[lindex]);
+--- a/src/cmds/qsub_functions.c        2015-03-17 16:43:36.000000000 -0400
++++ b/src/cmds/qsub_functions.c        2019-02-25 12:32:00.442982091 -0500
+@@ -542,7 +542,7 @@
+   static char tmpLine[65536];
+   /* we've reached the end */
+-  if ((start == NULL) && (*tok_ptr == '\0'))
++  if ((start == NULL) && (*tok_ptr == NULL))
+     return(0);
+   if (start != NULL)
+@@ -554,7 +554,7 @@
+     return(0);
+      
+   if ((*curr_ptr == '=') || 
+-      (*curr_ptr == '\0'))
++      (*curr_ptr == NULL))
+     {
+     /* no name, fail */
+     return(-1);
+@@ -574,18 +574,18 @@
+   /* strip blanks */
+   while ((*equals) && (isspace((int)*equals)))
+-    *equals++ = '\0';
++    *equals++ = NULL;
+   if (*equals != '=')
+     return (-1); /* should have found a = as first non blank */
+-  *equals++ = '\0';
++  *equals++ = NULL;
+   /* skip leading white space */
+   while (isspace((int)*equals) && *equals)
+     equals++;
+-  if (*equals == '\0')
++  if (*equals == NULL)
+     return(-1);
+   *value = equals;
+@@ -872,7 +872,7 @@
+   else
+     {
+     char *tmp_host = pbs_default();
+-    if (tmp_host == '\0')
++    if (tmp_host == NULL)
+       hash_add_or_exit(mm, job_attr, ATTR_pbs_o_server, qsub_host, LOGIC_DATA);
+     else
+       hash_add_or_exit(mm, job_attr, ATTR_pbs_o_server, tmp_host, LOGIC_DATA);
+--- a/src/include/attribute.h  2015-03-17 16:43:36.000000000 -0400
++++ b/src/include/attribute.h  2019-02-22 16:47:40.507695453 -0500
+@@ -445,7 +445,7 @@
+ extern int   parse_equal_string(char *, char **, char **);
+ extern char *parse_comma_string(char *,char **);
+-#define NULL_FUNC '\0'
++#define NULL_FUNC NULL
+ /* other associated funtions */
+ struct dynamic_string;
+--- a/src/resmom/mom_main.c    2015-03-17 16:43:36.000000000 -0400
++++ b/src/resmom/mom_main.c    2019-02-22 14:01:26.573890840 -0500
+@@ -4224,7 +4224,7 @@
+     goto done;
+     }
+-  name[i] = '\0';
++  name[i] = NULL;
+   for (d = ret_string, resline++;*resline;)
+     {
+--- a/src/server/job_attr_def.c        2015-03-17 16:43:36.000000000 -0400
++++ b/src/server/job_attr_def.c        2019-02-22 16:43:05.653007840 -0500
+@@ -1193,7 +1193,7 @@
+   },
+   /* JOB_ATR_system_start_time */
+-  {ATTR_system_start_time, /* start time as encoded in the proc/pid directory */
++  { (char *)ATTR_system_start_time, /* start time as encoded in the proc/pid directory */
+    decode_l,
+    encode_l,
+    set_l,
+@@ -1205,7 +1205,7 @@
+    PARENT_TYPE_JOB},
+   /* JOB_ATR_nppcu */
+-  {ATTR_nppcu, /* how to handle compute units (on Cray system) */
++  { (char *)ATTR_nppcu, /* how to handle compute units (on Cray system) */
+    decode_l,
+    encode_l,
+    set_l,
similarity index 93%
rename from sys-cluster/torque/torque-4.2.10.ebuild
rename to sys-cluster/torque/torque-4.2.10-r1.ebuild
index 769264fd387caeae289077977dc1c331131b6a86..7c06eb30b27e150842ee40ba572b0d7d96eb334d 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -9,7 +9,8 @@ DESCRIPTION="Resource manager and queuing system based on OpenPBS"
 HOMEPAGE="http://www.adaptivecomputing.com/products/open-source/torque"
 # TODO:  hopefully moving to github tags soon
 # http://www.supercluster.org/pipermail/torquedev/2013-May/004519.html
-SRC_URI="http://www.adaptivecomputing.com/index.php?wpfb_dl=2849 -> ${P}.tar.gz"
+#SRC_URI="http://www.adaptivecomputing.com/index.php?wpfb_dl=2849 -> ${P}.tar.gz"
+SRC_URI="https://github.com/adaptivecomputing/torque/archive/ddf5c4f40091b6157164a8846e5b60f42a5ae7f6.tar.gz -> ${P}-gh-20150517.tar.gz"
 
 LICENSE="torque-2.5"
 SLOT="0"
@@ -42,7 +43,7 @@ RDEPEND="${DEPEND_COMMON}
        !crypt? ( net-misc/netkit-rsh )
        !dev-libs/uthash"
 
-S="${WORKDIR}"/${PN}-4.2.9
+S="${WORKDIR}"/${PN}-ddf5c4f40091b6157164a8846e5b60f42a5ae7f6
 
 # Torque should depend on dev-libs/uthash but that's pretty much impossible
 # to patch in as they ship with a broken configure such that files referenced
@@ -90,14 +91,11 @@ src_prepare() {
        sed -i '/mk_default_ld_lib_file || return 1/d' buildutils/pbs_mkdirs.in || die
 
        eapply "${FILESDIR}"/${PN}-4.2.9-tcl8.6.patch
-
-       # 524362
-       eapply "${FILESDIR}"/TRQ-2885-limit-tm_adopt-to-only-adopt-a-session-id-t.patch
-
        eapply "${FILESDIR}"/${PN}-4.2-dont-mess-with-cflags.patch
+       eapply "${FILESDIR}"/${PN}-4.2-use-NULL-instead-of-char0.patch
        eapply_user
        mkdir -p "${S}"/m4
-       eautoconf
+       eautoreconf
 }
 
 src_configure() {