dev-util/packer: 1.4.4 drop use of golang-base
authorWilliam Hubbs <williamh@gentoo.org>
Sat, 21 Mar 2020 22:10:14 +0000 (17:10 -0500)
committerWilliam Hubbs <williamh@gentoo.org>
Sat, 21 Mar 2020 22:10:14 +0000 (17:10 -0500)
Signed-off-by: William Hubbs <williamh@gentoo.org>
dev-util/packer/packer-1.4.4.ebuild

index a361a43a1fa316327353c502d75e9616572b9d83..ab0e1cbcd571d23d5e0f7ef78d4c78ecf997ee70 100644 (file)
@@ -3,25 +3,21 @@
 
 EAPI=7
 
-inherit golang-base go-module
+inherit go-module
 
 DESCRIPTION="A tool to create identical machine images for multiple platforms"
 HOMEPAGE="https://www.packer.io"
-
-EGO_PN="github.com/hashicorp/packer"
 SRC_URI="https://github.com/hashicorp/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
 
 LICENSE="Apache-2.0 BSD-2 BSD-4 ECL-2.0 icu imagemagick ISC JSON MIT MPL-2.0"
-
 SLOT="0"
 KEYWORDS="~amd64"
-IUSE=""
-DEPEND=""
 
 DOCS=( {README,CHANGELOG}.md )
 
 src_compile() {
-       GOCACHE="${T}/go-cache" go build \
+       go build \
+               -mod=vendor \
                -work -o "bin/${PN}" ./ || die
 }