dev-python/google-api-core: New package
authorPatrick McLean <patrick.mclean@sony.com>
Wed, 13 May 2020 03:59:23 +0000 (20:59 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Wed, 13 May 2020 04:00:32 +0000 (21:00 -0700)
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
dev-python/google-api-core/Manifest [new file with mode: 0644]
dev-python/google-api-core/google-api-core-1.17.0.ebuild [new file with mode: 0644]
dev-python/google-api-core/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/google-api-core/Manifest b/dev-python/google-api-core/Manifest
new file mode 100644 (file)
index 0000000..620b2c9
--- /dev/null
@@ -0,0 +1 @@
+DIST google-api-core-1.17.0.tar.gz 98660 BLAKE2B 7959f429dbbfd8de658b11d0ee5be253cb53d930f8b37a140dbdc89a0d25ecdc640fc91476138471603efbe1e6078d668bc3f0e06c1fb1481960970a6f5632dc SHA512 fd609ce85bde22b09653bf46dd7bcc504ed93b19f8832c28f1d26ecb38a01e00380bd715191152a8d109e8c3235951b60525d4692fb4ba0eccb11a3b1df58cd2
diff --git a/dev-python/google-api-core/google-api-core-1.17.0.ebuild b/dev-python/google-api-core/google-api-core-1.17.0.ebuild
new file mode 100644 (file)
index 0000000..ad5c471
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="Core Library for Google Client Libraries"
+HOMEPAGE="https://github.com/googleapis/python-api-core
+       https://googleapis.dev/python/google-api-core/latest"
+SRC_URI="https://github.com/googleapis/${PN//google/python}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${P//google/python}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+       dev-python/namespace-google[${PYTHON_USEDEP}]
+       dev-python/protobuf-python[${PYTHON_USEDEP}]
+       dev-python/googleapis-common-protos[${PYTHON_USEDEP}]
+       >=dev-python/google-auth-1.14.0[${PYTHON_USEDEP}]
+       >=dev-python/requests-2.18.0[${PYTHON_USEDEP}]
+       <dev-python/requests-3[${PYTHON_USEDEP}]
+       dev-python/six[${PYTHON_USEDEP}]
+       dev-python/pytz[${PYTHON_USEDEP}]
+"
+BDEPEND="
+       test? (
+               dev-python/grpcio[${PYTHON_USEDEP}]
+       )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+       distutils_install_for_testing
+       pytest -vv || die "tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+       find "${D}" -name '*.pth' -delete || die
+}
diff --git a/dev-python/google-api-core/metadata.xml b/dev-python/google-api-core/metadata.xml
new file mode 100644 (file)
index 0000000..a50ee0d
--- /dev/null
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+  <maintainer type="person">
+    <email>chutzpah@gentoo.org</email>
+    <name>Patrick McLean</name>
+  </maintainer>
+  <stabilize-allarches/>
+</pkgmetadata>