dev-libs/clhpp: fix installation directory
authorMarek Szuba <marecki@gentoo.org>
Thu, 23 Apr 2020 00:25:25 +0000 (01:25 +0100)
committerMarek Szuba <marecki@gentoo.org>
Thu, 23 Apr 2020 00:31:25 +0000 (01:31 +0100)
Upstream now handles the global prefix correctly so there is no need to
set it to $EPREFIX/usr/include; simply $EPREFIX/usr - i.e. the Gentoo
default will do.

Closes: https://bugs.gentoo.org/716392
Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-libs/clhpp/clhpp-2.0.11-r1.ebuild [new file with mode: 0644]

diff --git a/dev-libs/clhpp/clhpp-2.0.11-r1.ebuild b/dev-libs/clhpp/clhpp-2.0.11-r1.ebuild
new file mode 100644 (file)
index 0000000..2325c35
--- /dev/null
@@ -0,0 +1,28 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="Khronos OpenCL C++ bindings"
+HOMEPAGE="https://github.com/KhronosGroup/OpenCL-CLHPP/"
+SRC_URI="https://github.com/KhronosGroup/OpenCL-CLHPP/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Khronos-CLHPP"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="virtual/opencl"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"/OpenCL-CLHPP-${PV}
+
+src_configure() {
+       local mycmakeargs=(
+               -DBUILD_DOCS=OFF
+               -DBUILD_EXAMPLES=OFF
+               -DBUILD_TESTS=OFF
+       )
+       cmake_src_configure
+}