dev-haskell/stringsearch: bump up to 0.3.6.6-r1
authorSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 13:26:43 +0000 (13:26 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Sat, 14 Dec 2019 14:05:39 +0000 (14:05 +0000)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
dev-haskell/stringsearch/stringsearch-0.3.6.6-r1.ebuild [new file with mode: 0644]

diff --git a/dev-haskell/stringsearch/stringsearch-0.3.6.6-r1.ebuild b/dev-haskell/stringsearch/stringsearch-0.3.6.6-r1.ebuild
new file mode 100644 (file)
index 0000000..54844c0
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+# ebuild generated by hackport 0.4.5.9999
+#hackport: flags: -base3,+base4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Fast searching, splitting and replacing of ByteStrings"
+HOMEPAGE="https://bitbucket.org/dafis/stringsearch"
+SRC_URI="https://hackage.haskell.org/package/${P}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/ghc-7.4.1:=
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.6
+"
+
+src_prepare() {
+       default
+
+       cabal_chdeps \
+               'containers >= 0.3 && < 0.6' 'containers >= 0.3'
+}
+
+src_configure() {
+       haskell-cabal_src_configure \
+               --flag=-base3 \
+               --flag=base4
+}