media-gfx/peps: remove 2.0-r0
authorMichael Palimaka <kensington@gentoo.org>
Thu, 22 Feb 2018 09:14:01 +0000 (20:14 +1100)
committerMichael Palimaka <kensington@gentoo.org>
Thu, 22 Feb 2018 09:14:13 +0000 (20:14 +1100)
Package-Manager: Portage-2.3.19, Repoman-2.3.6

media-gfx/peps/peps-2.0.ebuild [deleted file]

diff --git a/media-gfx/peps/peps-2.0.ebuild b/media-gfx/peps/peps-2.0.ebuild
deleted file mode 100644 (file)
index e232d29..0000000
+++ /dev/null
@@ -1,53 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="2"
-
-inherit eutils toolchain-funcs
-
-DESCRIPTION="Preprocess and convert EPS files to bitmap with Ghostscript"
-HOMEPAGE="http://peps.redprince.net/peps/"
-SRC_URI="http://www.peps.redprince.net/peps/${P}.tar.gz"
-
-LICENSE="BSD-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="X"
-
-DEPEND="app-text/ghostscript-gpl
-       app-arch/gzip"
-RDEPEND="${DEPEND}"
-
-pkg_setup() {
-       if use X && ! grep -q x11gray4 <(gs -h 2>/dev/null); then
-               die "you need a ghostscript version with 'x11' and 'x11gray4' devices!"
-       fi
-}
-
-src_prepare() {
-       # adding <string.h> include
-       sed -i -e "s:^\(#include.*<unistd.h>.*\):\1\n#include <string.h>:" peps.c
-       # adding LDFLAGS to Makefile
-       sed -i -e "s:\( -o \): \${LDFLAGS}\1:g" Makefile
-}
-
-src_compile() {
-       local myopts="peps"
-       use X && myopts="${myopts} xpeps"
-       emake CC="$(tc-getCC)" ${myopts} || die "emake failed"
-}
-
-src_install() {
-       # manual install, because fixing dumb Makefile is more compilcated
-       dobin peps || die "install failed"
-       use X && dobin xpeps
-
-       doman peps.1
-       dodoc README
-
-       insinto /etc
-       doins peps.mime
-
-       # copy PDF so it won't be compressed
-       cp peps.pdf "${D}usr/share/doc/${PF}"
-}