dev-python/colorclass: New package, test-dep of tabulate & others
authorMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:06:33 +0000 (14:06 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 7 Jul 2019 12:06:33 +0000 (14:06 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/colorclass/Manifest [new file with mode: 0644]
dev-python/colorclass/colorclass-2.2.0.ebuild [new file with mode: 0644]
dev-python/colorclass/metadata.xml [new file with mode: 0644]

diff --git a/dev-python/colorclass/Manifest b/dev-python/colorclass/Manifest
new file mode 100644 (file)
index 0000000..eb29817
--- /dev/null
@@ -0,0 +1 @@
+DIST colorclass-2.2.0.gh.tar.gz 486151 BLAKE2B d8f4c9e826cf284df47bf2aac4da71f448818858e2383b331b5bba791d9db3c5c11d5aff74b3eb740e657914137b2b74b217854ab589806a22a0ff6697cbde1c SHA512 c627cdf6abdb5a60e9ecc1fb3b669898edc027fdc3f8cde31be2e10402ee308c2067fcd50d1228759e93fc58c521b7fc12e6b259233a17cf99f55cda26279fed
diff --git a/dev-python/colorclass/colorclass-2.2.0.ebuild b/dev-python/colorclass/colorclass-2.2.0.ebuild
new file mode 100644 (file)
index 0000000..3a2e9a6
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1
+
+DESCRIPTION="Colorful worry-free console applications for multiple platforms"
+HOMEPAGE="https://pypi.org/project/colorclass/ https://github.com/Robpol86/colorclass"
+SRC_URI="https://github.com/Robpol86/colorclass/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       pytest -vv || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/colorclass/metadata.xml b/dev-python/colorclass/metadata.xml
new file mode 100644 (file)
index 0000000..266e3f1
--- /dev/null
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>python@gentoo.org</email>
+       </maintainer>
+</pkgmetadata>