media-gfx/imv: Update live ebuild
authorJeroen Roovers <jer@gentoo.org>
Mon, 16 Dec 2019 09:59:50 +0000 (10:59 +0100)
committerJeroen Roovers <jer@gentoo.org>
Mon, 16 Dec 2019 10:02:50 +0000 (11:02 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Jeroen Roovers <jer@gentoo.org>
media-gfx/imv/imv-9999.ebuild

index 275366fe87f1491e5113398384d044aa1148e4da..927a92ad359570f125bb077b1ac2a76a677a36be 100644 (file)
@@ -1,30 +1,83 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=6
-
-inherit xdg-utils git-r3
+EAPI=7
+inherit git-r3 toolchain-funcs xdg-utils
 
 DESCRIPTION="Minimal image viewer designed for tiling window manager users"
 HOMEPAGE="https://github.com/eXeC64/imv"
-EGIT_REPO_URI="https://github.com/eXeC64/imv.git"
+EGIT_REPO_URI="https://github.com/eXeC64/imv"
 
 LICENSE="GPL-2+"
 SLOT="0"
 KEYWORDS=""
-IUSE="test"
+IUSE="X +freeimage jpeg png svg test tiff wayland"
 RESTRICT="!test? ( test )"
+REQUIRED_USE="
+       || ( X wayland )
+"
 
 RDEPEND="
        !sys-apps/renameutils
        media-libs/fontconfig
        media-libs/libsdl2
        media-libs/sdl2-ttf
-       media-libs/freeimage
+       X? (
+               x11-libs/pango
+               x11-libs/libX11
+       )
+       freeimage? ( media-libs/freeimage )
+       jpeg? ( media-libs/libjpeg-turbo )
+       png? ( media-libs/libpng )
+       svg? ( gnome-base/librsvg )
+       tiff? ( media-libs/tiff )
+       wayland? ( dev-libs/wayland )
+"
+BDEPEND="
+       app-text/asciidoc
+       test? ( dev-util/cmocka )
 "
+DEPEND="
+       ${RDEPEND}
+"
+
+src_prepare() {
+       default
+       sed -i -e 's|pkg-config|$(PKG_CONFIG)|g' Makefile || die
+}
 
-DEPEND="${RDEPEND}
-       test? ( dev-util/cmocka )"
+src_configure() {
+       tc-export PKG_CONFIG
+       local WINDOWS
+       if use X; then
+               if ! use wayland; then
+                       WINDOWS=x11
+               else
+                       WINDOWS=all
+               fi
+       else
+               if use wayland; then
+                       WINDOWS=wayland
+               fi
+       fi
+
+       BACKENDS=(
+               BACKEND_FREEIMAGE=$(usex freeimage)
+               BACKEND_JPEG=$(usex jpeg)
+               BACKEND_LIBPNG=$(usex png)
+               BACKEND_LIBRSVG=$(usex svg)
+               BACKEND_LIBTIFF=$(usex tiff)
+               WINDOWS=${WINDOWS}
+       )
+}
+
+src_compile() {
+       emake ${BACKENDS[@]}
+}
+
+src_install() {
+       emake ${BACKENDS[@]} DESTDIR="${D}" install
+}
 
 pkg_postinst() {
        xdg_desktop_database_update