app-i18n/fcitx-sunpinyin: Add live ebuild.
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>
Thu, 19 Oct 2017 20:55:39 +0000 (22:55 +0200)
committerMike Gilbert <floppym@gentoo.org>
Mon, 23 Oct 2017 17:24:42 +0000 (13:24 -0400)
app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild [new file with mode: 0644]

diff --git a/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild b/app-i18n/fcitx-sunpinyin/fcitx-sunpinyin-4.9999.ebuild
new file mode 100644 (file)
index 0000000..20c11e0
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit cmake-utils gnome2-utils
+
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+       inherit git-r3
+
+       EGIT_REPO_URI="https://github.com/fcitx/fcitx-sunpinyin"
+fi
+
+DESCRIPTION="Chinese SunPinyin input method for Fcitx"
+HOMEPAGE="https://fcitx-im.org/ https://github.com/fcitx/fcitx-sunpinyin"
+if [[ "${PV}" =~ (^|\.)9999$ ]]; then
+       SRC_URI=""
+else
+       SRC_URI="https://download.fcitx-im.org/${PN}/${P}.tar.xz"
+fi
+
+LICENSE="GPL-2+"
+SLOT="4"
+KEYWORDS=""
+IUSE=""
+
+RDEPEND=">=app-i18n/fcitx-4.2.9:4
+       >=app-i18n/sunpinyin-2.0.4_alpha:=
+       virtual/libintl"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+DOCS=(AUTHORS)
+
+pkg_postinst() {
+       gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+       gnome2_icon_cache_update
+}