dev-libs/folks: don't require dbusmock without tests being built
authorMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 17:35:09 +0000 (19:35 +0200)
committerMart Raudsepp <leio@gentoo.org>
Sun, 23 Feb 2020 17:35:53 +0000 (19:35 +0200)
The upstream meson-0.53 fix made the dbusmock check actually effective,
erroring out if not found when bluetooth is enabled. We already have
a patch downstream to make build of tests conditional, so build on
top of that to skip the dbusmock check when tests aren't being built.

Fixes: 61a9ee210b2d44c4fa953342504293a89395bef0
Closes: https://bugs.gentoo.org/710548
Package-Manager: Portage-2.3.84, Repoman-2.3.20
Signed-off-by: Mart Raudsepp <leio@gentoo.org>
dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch [new file with mode: 0644]
dev-libs/folks/folks-0.12.1-r1.ebuild

diff --git a/dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch b/dev-libs/folks/files/0.12.1-meson-0.53-compat2.patch
new file mode 100644 (file)
index 0000000..40c3ca6
--- /dev/null
@@ -0,0 +1,31 @@
+From f8a59fb6bf12be06595c94d0b00afed4e1d2f1ee Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Sun, 23 Feb 2020 19:28:51 +0200
+Subject: [PATCH] meson: Conditionalize dbusmock check to tests being built
+
+---
+ meson.build | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/meson.build b/meson.build
+index 74320634..64f28d2b 100644
+--- a/meson.build
++++ b/meson.build
+@@ -131,12 +131,14 @@ endif
+ if bluez_backend_enabled
+   libebook_dep = dependency('libebook-1.2', version: '>=' + min_eds_version)
+   # Needed for the BlueZ tests
++  if get_option('test')
+   pymod = import('python')
+   py_installation = pymod.find_installation('python3',
+     modules: [
+       'dbusmock',
+     ],
+   )
++  endif
+ endif
+ if import_tool_enabled
+-- 
+2.20.1
+
index 51ddb26a5e316c99540d7d035b3e5f509a231d45..633ff457fbe2875b65a1e3375e7ab385c19a6707 100644 (file)
@@ -48,8 +48,9 @@ BDEPEND="
 
 PATCHES=(
        "${FILESDIR}"/${PV}-conditional-tests.patch # Allow not building lots of test executables when tests are disabled
-       "${FILESDIR}"/${PV}-no-tracker-tests.patch # TODO: Tracker tests fail; this removed them for now
+       "${FILESDIR}"/${PV}-no-tracker-tests.patch # TODO: Tracker tests fail; this removes them for now
        "${FILESDIR}"/${PV}-meson-0.53-compat.patch # https://gitlab.gnome.org/GNOME/folks/issues/119
+       "${FILESDIR}"/${PV}-meson-0.53-compat2.patch # Don't require dbusmock if tests aren't built (with our downstream conditional-tests patch)
 )
 
 src_prepare() {