media-gfx/graphite2: Drop 1.3.10
authorAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 21:01:23 +0000 (22:01 +0100)
committerAndreas Sturmlechner <asturm@gentoo.org>
Wed, 25 Dec 2019 21:20:13 +0000 (22:20 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
media-gfx/graphite2/Manifest
media-gfx/graphite2/graphite2-1.3.10.ebuild [deleted file]

index 091edba80f858b3a3006fb96817a5b1c509a3135..d1930261a2b9c7bea7c422cd27528f5633d5ad20 100644 (file)
@@ -1,2 +1 @@
-DIST graphite2-1.3.10.tgz 3889647 BLAKE2B c6db80950ed5f81d5ecf77003e23e6545c2824948bdc04aa3111747c0eb1ef074b09fe4c3ec20b68b00f75958ea39c5945a7fbe2fecde55ff32d22e517c91156 SHA512 d6d578feaa2d9304dc9bcd3926958070b8c23b27437a9fcb801e08e62f33a5549b7a6aa9636c7f8eb80a2a2c6d5cac97d58050fb30fd102b9fd0f8c558f4252b
 DIST graphite2-1.3.13.tgz 6664757 BLAKE2B 3faad44f7ba5e0729f722fd4589c5f6a4c53cffc2bb93615c8220d03c759dedf05924b1f56cafcf1c28e0a4b50fba0d319da30572fffde4baab6bc240528a0d3 SHA512 44ac2f353c1a795a55c78b4ff72df35a3a5a94700356c0eefe105d66cd499ac93f9cfd5ab7b3ea842b575156cb8df19e0b57ff8b9dbaee8a576319ff5889c131
diff --git a/media-gfx/graphite2/graphite2-1.3.10.ebuild b/media-gfx/graphite2/graphite2-1.3.10.ebuild
deleted file mode 100644 (file)
index 54c11d8..0000000
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 )
-
-GENTOO_DEPEND_ON_PERL="no"
-inherit eutils perl-module python-any-r1 cmake-multilib
-
-DESCRIPTION="Library providing rendering capabilities for complex non-Roman writing systems"
-HOMEPAGE="http://graphite.sil.org/"
-SRC_URI="mirror://sourceforge/silgraphite/${PN}/${P}.tgz"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
-IUSE="perl test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       perl? ( dev-lang/perl:= )
-"
-DEPEND="${RDEPEND}
-       perl? (
-               dev-perl/Module-Build
-               dev-perl/Locale-Maketext-Lexicon
-               )
-       test? (
-               dev-libs/glib:2
-               media-libs/fontconfig
-               $(python_gen_any_dep '
-                       dev-python/fonttools[${PYTHON_USEDEP}]
-               ')
-               ${PYTHON_DEPS}
-               perl? ( virtual/perl-Test-Simple )
-       )
-"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-1.3.5-includes-libs-perl.patch"
-)
-
-pkg_setup() {
-       use perl && perl_set_version
-       use test && python-any-r1_pkg_setup
-}
-
-python_check_deps() {
-       has_version "dev-python/fonttools[${PYTHON_USEDEP}]"
-}
-
-src_prepare() {
-       cmake-utils_src_prepare
-
-       # make tests optional
-       if ! use test; then
-               sed -i \
-                       -e '/tests/d' \
-                       CMakeLists.txt || die
-       fi
-}
-
-multilib_src_configure() {
-       local mycmakeargs=(
-               "-DVM_MACHINE_TYPE=direct"
-               # https://sourceforge.net/p/silgraphite/bugs/49/
-               $([[ ${CHOST} == powerpc*-apple* ]] && \
-                       echo "-DGRAPHITE2_NSEGCACHE:BOOL=ON")
-       )
-
-       cmake-utils_src_configure
-
-       # fix perl linking
-       if multilib_is_native_abi && use perl; then
-               # we rely on the fact that cmake-utils_src_configure sets BUILD_DIR
-               sed -i \
-                       -e "s:@BUILD_DIR@:\"${BUILD_DIR}/src\":" \
-                       "${S}"/contrib/perl/Build.PL || die
-       fi
-}
-
-src_compile() {
-       cmake-multilib_src_compile
-       if use perl; then
-               cd contrib/perl || die
-               perl-module_src_configure
-               perl-module_src_compile
-       fi
-}
-
-multilib_src_test() {
-       if multilib_is_native_abi; then
-               cmake-utils_src_test
-       else
-               einfo Cannot test since python is not multilib.
-       fi
-}
-
-src_test() {
-       cmake-multilib_src_test
-       if use perl; then
-               # Perl tests fail due to missing POD coverage...
-               perl_rm_files "contrib/perl/t/pod.t" "contrib/perl/t/pod-coverage.t"
-               cd contrib/perl || die
-               perl-module_src_test
-       fi
-}
-
-src_install() {
-       cmake-multilib_src_install
-       if use perl; then
-               cd contrib/perl || die
-               perl-module_src_install
-               perl_delete_localpod
-       fi
-
-       prune_libtool_files --all
-}