games-puzzle/angrydd: Fixes from Debian, python3 support
authorPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 19:07:25 +0000 (20:07 +0100)
committerPacho Ramos <pacho@gentoo.org>
Wed, 25 Dec 2019 19:30:22 +0000 (20:30 +0100)
Package-Manager: Portage-2.3.82, Repoman-2.3.20
Signed-off-by: Pacho Ramos <pacho@gentoo.org>
games-puzzle/angrydd/Manifest
games-puzzle/angrydd/angrydd-1.0.1_p13.ebuild [new file with mode: 0644]

index 5faf1a793b2d865bd39979d08ae6057730dcd8da..d8398d1cbf67580097c3524cb05951324e77f5ae 100644 (file)
@@ -1 +1,2 @@
 DIST angrydd-1.0.1.tar.gz 5331883 BLAKE2B de8a418b881f17e0869d9b8004b6db3cee56c1bb05729a5238f6357d3072ff10afb864252fcb3cef5c90d136ad7c8739afd71b88c932545203f2e9752c5eac81 SHA512 e0901833febcabb6622bb85405189bfaf3c917c3254ce282045d58e8e5b5c6c6565ca0e7c56fe2819e0d3f344df3bb285cca54c360b467d284739673d1aa74f0
+DIST angrydd_1.0.1-13.debian.tar.xz 11940 BLAKE2B d64ae1f878f3dfe4eee9f236ce6869f7ce3d77021a09593240a84860157781ecd776be7a06edbb48d1e340c654c50f4463b76b42049076e9c02b6397988ca9df SHA512 123d593ac7ceff8f6fe5d70442b92e6564f4e6ee668450cb623bbdeb4633cad6e04cf896d93cacc5e11bda08cb61b7c92ce0b99072e6e12b21e023620d12b360
diff --git a/games-puzzle/angrydd/angrydd-1.0.1_p13.ebuild b/games-puzzle/angrydd/angrydd-1.0.1_p13.ebuild
new file mode 100644 (file)
index 0000000..24ba065
--- /dev/null
@@ -0,0 +1,54 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit desktop python-single-r1
+
+DESCRIPTION="Angry, Drunken Dwarves, a falling blocks game similar to Puzzle Fighter"
+HOMEPAGE="https://www.sacredchao.net/~piman/angrydd/"
+SRC_URI="
+       https://www.sacredchao.net/~piman/angrydd/${P/_p*}.tar.gz
+       mirror://debian/pool/main/${PN:0:1}/${PN}/${PN}_${PV/_p*}-${PV/*_p}.debian.tar.xz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE=""
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+
+RDEPEND="${PYTHON_DEPS}
+       dev-python/pygame[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${P/_p*}"
+
+src_prepare() {
+       default
+       eapply -p1 "${WORKDIR}"/debian/patches/*.patch
+       python_fix_shebang .
+}
+
+src_install() {
+       emake \
+               DESTDIR="${D}" \
+               PREFIX="/usr/share/" \
+               TO="${PN}" \
+               install
+       rm -rf "${ED}/usr/share/games" "${ED}/usr/share/share" || die
+
+       python_optimize "${ED}/usr/share/${PN}"
+
+       dodir /usr/bin
+       dosym "../share/${PN}/angrydd.py" "/usr/bin/${PN}"
+       doman angrydd.6
+       dodoc README TODO HACKING
+
+       doicon angrydd.png
+       make_desktop_entry angrydd "Angry, Drunken Dwarves"
+}