sci-mathematics/rstudio: fix slashes
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 22 Aug 2019 11:07:28 +0000 (13:07 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 22 Aug 2019 11:07:28 +0000 (13:07 +0200)
Package-Manager: Portage-2.3.72, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
sci-mathematics/rstudio/rstudio-1.1.463-r1.ebuild

index 86b6db8da4ba74bbfcb83a9252abeee5e67cf513..cc1c95318e3aed6e192c25fc26b710a79438be48 100644 (file)
@@ -164,12 +164,12 @@ src_prepare() {
                CMakeGlobals.txt src/cpp/desktop/CMakeLists.txt || die
 
        # On Gentoo the rstudio-server configuration file is /etc/conf.d/rstudio-server.conf
-       sed -e "s@/etc/rstudio/rserver.conf@${EROOT}etc/conf.d/rstudio-server.conf@" \
+       sed -e "s@/etc/rstudio/rserver.conf@${EROOT}/etc/conf.d/rstudio-server.conf@" \
                -i src/cpp/server/ServerOptions.cpp \
                || die
 
        # Set the rsession.conf file location for Gentoo prefix
-       sed -e "s@/etc/rstudio/rsession.conf@${EROOT}etc/rstudio/rsession.conf@" \
+       sed -e "s@/etc/rstudio/rsession.conf@${EROOT}/etc/rstudio/rsession.conf@" \
                -i src/cpp/session/SessionOptions.cpp \
                || die
 
@@ -225,7 +225,7 @@ src_install() {
        dodir /etc/rstudio
        insinto /etc/rstudio
        doins "${FILESDIR}"/rsession.conf
-       dosym "${ROOT}etc/conf.d/rstudio-server.conf" "${ROOT}etc/rstudio/rserver.conf"
+       dosym "${EROOT}/etc/conf.d/rstudio-server.conf" "/etc/rstudio/rserver.conf"
        if use dedicated || use server; then
                dopamd src/cpp/server/extras/pam/rstudio
                newinitd "${FILESDIR}"/rstudio-server.initd rstudio-server