Various man/emerge.1 fixes from Benno Schulenberg in bug #136818. This patch is from...
authorZac Medico <zmedico@gentoo.org>
Wed, 21 Jun 2006 02:18:57 +0000 (02:18 -0000)
committerZac Medico <zmedico@gentoo.org>
Wed, 21 Jun 2006 02:18:57 +0000 (02:18 -0000)
svn path=/main/branches/2.1/; revision=3564

man/emerge.1

index 5af1799a203a11311cb182d3488076b3c6406010..2398587162667a7cda0b11cbf85a31b1b836946a 100644 (file)
@@ -39,7 +39,8 @@ as \fBsys\-apps/portage\fR or \fB=python\-2.2.1\-r2\fR.
 ignores a trailing slash so that filename completion can be used.
 The \fIebuild\fR may also be an actual filename, such as
 \fB/usr/portage/app\-admin/python/python\-2.2.1\-r2.ebuild\fR.
-WARNING: The implementation of \fBemerge /path/to/ebuild\fR is broken and so this syntax shouldn't be used.
+WARNING: The implementation of \fBemerge /path/to/ebuild\fR is broken and so 
+this syntax shouldn't be used.
 .TP
 .BR tbz2file
 A \fItbz2file\fR must be a valid .tbz2 created with \fBebuild
@@ -47,14 +48,14 @@ A \fItbz2file\fR must be a valid .tbz2 created with \fBebuild
 [category/]<package>\fR or \fBquickpkg /var/db/pkg/<category>/<package>\fR.
 .TP
 .BR set
-Package sets are a convenient shorthand for large groups of
+A \fIset\fR is a convenient shorthand for a large group of
 packages.  Two sets are currently supported: \fBsystem\fR
 and \fBworld\fR.  \fBsystem\fR refers to a set of packages
 deemed necessary for your system to run properly.  \fBworld\fR
-contains all of the packages in \fBsystem\fR, along with any
+contains all the packages in \fBsystem\fR, plus any
 other packages listed in \fB/var/lib/portage/world\fR.  [See
-\fBFILES\fR below for more information.]  Note that these
-commands are generally used in conjunction with \fB\-\-update\fR.
+\fBFILES\fR below for more information.]  Note that a \fIset\fR
+is generally used in conjunction with \fB\-\-update\fR.
 .TP
 .BR dependency
 A \fIdependency\fR describes bounds on a package that you wish to install.  
@@ -85,6 +86,11 @@ clean binutils\fR cleans out old versions of binutils;
 specific version of Mozilla.  This is generally safe to use.
 \fBNote that\fR \-\-clean \fBdoes not remove unslotted packages.\fR
 .TP
+.BR "\-\-config "
+Run package specific actions needed to be executed after the emerge process 
+has completed.  This usually entails configuration file setup or other similar 
+setups that the user may wish to run.
+.TP
 .BR \-\-depclean
 Determines all packages installed on the system that have no 
 explicit reason for being there.  \fBemerge\fR generates a list 
@@ -107,8 +113,8 @@ updated more frequently than this man page; check it out if you
 are having problems that this man page does not help resolve.
 .TP
 .BR \-\-info
-This is a list of information to include in bug reports which aids the 
-developers with fixing any problems you may report.  \fBPlease include this 
+Produces a list of information to include in bug reports which aids the 
+developers when fixing the reported problem.  \fBPlease include this 
 information when submitting a bug report.\fR  Expanded output can be obtained 
 with the \fI\-\-verbose\fR option.
 .TP
@@ -180,11 +186,6 @@ use this option only in combination with the world or system target.
 .TP
 .BR "\-\-version " (\fB\-V\fR)
 Displays the version number of \fBemerge\fR.
-.TP
-.BR "\-\-config "
-Run package specific actions needed to  be  executed  after  the
-emerge  process  has completed.  This usually entails configuration
-file setup or other similar setups that the user  may  wish to run.
 .SH "OPTIONS"
 .TP
 .BR "\-\-alphabetical "
@@ -256,7 +257,8 @@ files.
 Using the server and location defined in \fIPORTAGE_BINHOST\fR (see 
 \fBmake.conf\fR(5)), portage will download the information from each binary 
 package found and it will use that information to help build the dependency 
-list.  This option implies \fB\-k\fR.  (Use \fB\-gK\fR for binary\-only merging.)
+list.  This option implies \fB\-k\fR.  (Use \fB\-gK\fR for binary\-only 
+merging.)
 .TP
 .BR "\-\-getbinpkgonly " (\fB\-G\fR)
 This option is identical to \fB\-g\fR, as above, except it will not use ANY 
@@ -273,7 +275,7 @@ compilation.  An asterisk marks when a USE flag has changed since the package
 was compiled.
 .TP
 .BR "\-\-nocolor "
-Make sure none of the output from portage contains color.
+Suppresses all coloring of portage's output.
 .TP
 .BR "\-\-noconfmem"
 Causes portage to disregard merge records indicating that a config file
@@ -309,23 +311,23 @@ specified, not the packages themselves.
 Instead of actually performing the merge, simply display what *would*
 have been installed if \fB\-\-pretend\fR weren't used.  Using \fB\-\-pretend\fR
 is strongly recommended before installing an unfamiliar package.  In
-the printout
+the printout:
 .br 
  
 .br 
-\fIN\fR = new, (not yet installed)
+\fIN\fR = new (not yet installed)
 .br 
-\fIS\fR = new, SLOT installation (side-by-side versions) 
+\fIS\fR = new SLOT installation (side-by-side versions) 
 .br 
-\fIU\fR = updating, (changing versions)
+\fIU\fR = updating (to another version)
 .br 
-\fID\fR = downgrade, (Best version seems lower) 
+\fID\fR = downgrading (best version seems lower)
 .br 
-\fIR\fR = replacing, (Remerging same version))
+\fIR\fR = replacing (remerging same version))
 .br 
-\fIF\fR = fetch restricted, (Manual download)
+\fIF\fR = fetch restricted (must be manually downloaded)
 .br 
-\fIf\fR = fetch restricted, (Already downloaded)
+\fIf\fR = fetch restricted (already downloaded)
 .br 
 \fIB\fR = blocked by an already installed package
 .TP
@@ -345,9 +347,10 @@ This is only really useful in combination with \fB\-\-emptytree\fR or
 \fB\-\-update\fR and \fB\-\-deep\fR.
 .TP
 .BR "\-\-usepkg " (\fB\-k\fR) 
-Tells emerge to use binary packages (from $PKGDIR) if they are available, thus possibly avoiding some 
-time\-consuming compiles.  This option is useful for CD installs; you can export PKGDIR=/mnt/cdrom/packages 
-and then use this option to have emerge "pull" binary packages from the CD in order to satisfy dependencies.
+Tells emerge to use binary packages (from $PKGDIR) if they are available, thus 
+possibly avoiding some time\-consuming compiles.  This option is useful for CD 
+installs; you can export PKGDIR=/mnt/cdrom/packages and then use this option to 
+have emerge "pull" binary packages from the CD in order to satisfy dependencies.
 .TP
 .BR "\-\-usepkgonly " (\fB\-K\fR)
 Tells emerge to only use binary packages (from $PKGDIR).  All the binary 
@@ -356,7 +359,9 @@ will simply abort.  Portage does not use $PORTDIR when calculating dependency
 information so all masking information is ignored.
 .TP
 .BR "\-\-verbose " (\fB\-v\fR)
-Tell emerge to run in verbose mode.  Currently this flag causes emerge to print out GNU info errors, if any, and to show the USE flags that will be used for each package when pretending.
+Tell emerge to run in verbose mode.  Currently this flag causes emerge to print 
+out GNU info errors, if any, and to show the USE flags that will be used for 
+each package when pretending.
 .SH "ENVIRONMENT OPTIONS"
 .TP
 \fBROOT\fR = \fI[path]\fR
@@ -366,7 +371,8 @@ merging packages or ebuilds.
 Defaults to /.
 .TP
 \fBPORTAGE_CONFIGROOT\fR = \fI[path]\fR
-Use \fBPORTAGE_CONFIGROOT\fR to specify the location for various portage configuration files
+Use \fBPORTAGE_CONFIGROOT\fR to specify the location for various portage 
+configuration files
 (see \fBFILES\fR for a detailed list).
 .br
 Defaults to /.
@@ -488,11 +494,11 @@ each package that let \fBportage\fR know which systems are compatible with
 the package.  Packages which compile on an architecture, but have not been 
 proven to be "stable", are masked with a tilde (\fB~\fR) in front of the 
 architecture name.  \fBemerge\fR examines the \fBACCEPT_KEYWORDS\fR environment 
-variable to allow or disallow the emerging of a package masked by \fBKEYWORDS\fR.  
-To inform \fBemerge\fR that it should build these 'testing' versions 
-of packages, you should update your \fI/etc/portage/package.keywords\fR file 
-to list the packages you want the 'testing' version.  See \fBportage\fR(5) for 
-more information.
+variable to allow or disallow the emerging of a package masked by 
+\fBKEYWORDS\fR.  To inform \fBemerge\fR that it should build these 'testing' 
+versions of packages, you should update your 
+\fI/etc/portage/package.keywords\fR file to list the packages you want the 
+'testing' version.  See \fBportage\fR(5) for more information.
 .SH "REPORTING BUGS"
 Please report any bugs you encounter through our website:
 .LP