sys-kernel/linux-firmware: new snapshot
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
Tue, 1 Sep 2015 21:34:02 +0000 (23:34 +0200)
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
Tue, 1 Sep 2015 21:34:02 +0000 (23:34 +0200)
Package-Manager: portage-2.2.20.1

sys-kernel/linux-firmware/Manifest
sys-kernel/linux-firmware/linux-firmware-20150812.ebuild [new file with mode: 0644]

index ac2ae81df3421203844d8c26ae3c28757c6305e9..a4fc90adfa85f60ac62ab588767057f73eabd518 100644 (file)
@@ -4,3 +4,4 @@ DIST linux-firmware-20140902.tar.xz 24277312 SHA256 3dbf463d6deb559ce071de7f9f98
 DIST linux-firmware-20141009.tar.xz 24288396 SHA256 b3423bc48bdb46d89707096d9bed3eb0e59ec9172b52ad61d49d996f49f09f61 SHA512 d599abc518e95834118311428fd5cb3e5de47a25a264397758f8456bb3e1e1ed751d0fbfccc5196bd153c1fa4c0e477a7e2e6706f44ef1ba83bcab94b34d5ca3 WHIRLPOOL fd9f13f951c17fcff4db2981f0a71e91dde8b14639746d92ab51a16720758e1f3044a6c718580b5c662cb5a6e571e23739bceb7a8ea9ffe54d2492216efa4320
 DIST linux-firmware-20150206.tar.xz 25831872 SHA256 d9c9d87263cdff827b38bcd99c8a196230b3edc66c0f23d33da31718bad151ec SHA512 67d45da2ab7f6657b89b8c176c8906cbab82a502ac421d2d615dc6f20f7ef10ec49327a154624dcc28369a71ee34963712041c4a7c70b8995cdddb0fdb07093d WHIRLPOOL 2da562600d6e89a58f61a3783a8911ea0d186e9435a032fc224e18802c02159223c08c26f89150052174eef4b586b65913a8fe34b9cbd0c26202c2af3bd86147
 DIST linux-firmware-20150320.tar.xz 27113932 SHA256 0eafba794ea53b9f5f10714bd8d320b0c1d704801726b28072a99fd71606ba59 SHA512 280663d072eb4dd987ebbcb8b4508a167f3caa45dd21e3e6c8f8abfe6a90a5b9379f71ba4cd576e942a856b378c2d8a6f1e508cd16c7c59ac602ea36dff85ba3 WHIRLPOOL cdf9b5c136aba2cfa547e489e0273deedecab1fb4dfb2743b1fcb0d6ab2a0722702df7036ed0a299450f4257d33e0bd3ca23d650992a0a3df1901c996ba9a5d0
+DIST linux-firmware-20150812.tar.xz 30620844 SHA256 588c3d7882174a09a7061f08d37e1853270ab32911516fadf2a3e069040499f8 SHA512 0636f1cd1f795907e427ae45a0504d2bec5cdde7a1a355c3e13237ca65ec6501d01e7b35049a70d5b6ce9ab9cecef29ecbc1aa5258e0d157b3d59c6c56edc133 WHIRLPOOL 3a03ebd5620f6611c452271955d69f232ea61d34716dff6a0ab864909f01e2c3ea86ade664cef689cbc52e34723328b870c208fb9366d585f661fa232e51cfa4
diff --git a/sys-kernel/linux-firmware/linux-firmware-20150812.ebuild b/sys-kernel/linux-firmware/linux-firmware-20150812.ebuild
new file mode 100644 (file)
index 0000000..56a515d
--- /dev/null
@@ -0,0 +1,109 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit savedconfig
+
+if [[ ${PV} == 99999999* ]]; then
+       inherit git-2
+       SRC_URI=""
+       EGIT_REPO_URI="git://git.kernel.org/pub/scm/linux/kernel/git/firmware/${PN}.git"
+       KEYWORDS=""
+else
+       SRC_URI="mirror://gentoo/${P}.tar.xz"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+DESCRIPTION="Linux firmware files"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/firmware/linux-firmware.git"
+
+LICENSE="GPL-1 GPL-2 GPL-3 BSD freedist"
+SLOT="0"
+IUSE="savedconfig"
+
+DEPEND=""
+RDEPEND="!savedconfig? (
+               !sys-firmware/alsa-firmware[alsa_cards_ca0132]
+               !sys-firmware/alsa-firmware[alsa_cards_korg1212]
+               !sys-firmware/alsa-firmware[alsa_cards_maestro3]
+               !sys-firmware/alsa-firmware[alsa_cards_sb16]
+               !sys-firmware/alsa-firmware[alsa_cards_ymfpci]
+               !media-tv/cx18-firmware
+               !<sys-firmware/ivtv-firmware-20080701-r1
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx231xx]
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_cx23885]
+               !media-tv/linuxtv-dvb-firmware[dvb_cards_usb-dib0700]
+               !net-dialup/ueagle-atm
+               !net-dialup/ueagle4-atm
+               !net-wireless/ar9271-firmware
+               !net-wireless/i2400m-fw
+               !net-wireless/libertas-firmware
+               !sys-firmware/rt61-firmware
+               !net-wireless/rt73-firmware
+               !net-wireless/rt2860-firmware
+               !net-wireless/rt2870-firmware
+               !sys-block/qla-fc-firmware
+               !sys-firmware/amd-ucode
+               !sys-firmware/iwl1000-ucode
+               !sys-firmware/iwl2000-ucode
+               !sys-firmware/iwl2030-ucode
+               !sys-firmware/iwl3945-ucode
+               !sys-firmware/iwl4965-ucode
+               !sys-firmware/iwl5000-ucode
+               !sys-firmware/iwl5150-ucode
+               !sys-firmware/iwl6000-ucode
+               !sys-firmware/iwl6005-ucode
+               !sys-firmware/iwl6030-ucode
+               !sys-firmware/iwl6050-ucode
+               !sys-firmware/iwl3160-ucode
+               !sys-firmware/iwl7260-ucode
+               !sys-firmware/iwl7265-ucode
+               !sys-firmware/iwl3160-7260-bt-ucode
+               !x11-drivers/radeon-ucode
+       )"
+#add anything else that collides to this
+
+src_unpack() {
+       if [[ ${PV} == 99999999* ]]; then
+               git-2_src_unpack
+       else
+               default
+               # rename directory from git snapshot tarball
+               mv ${PN}-*/ ${P} || die
+       fi
+}
+
+src_prepare() {
+       echo "# Remove files that shall not be installed from this list." > ${PN}.conf
+       find * \( \! -type d -and \! -name ${PN}.conf \) >> ${PN}.conf
+
+       if use savedconfig; then
+               restore_config ${PN}.conf
+               ebegin "Removing all files not listed in config"
+               find * \( \! -type d -and \! -name ${PN}.conf \) \
+                       | sort ${PN}.conf ${PN}.conf - \
+                       | uniq -u | xargs -r rm
+               eend $? || die
+               # remove empty directories, bug #396073
+               find -type d -empty -delete || die
+       fi
+}
+
+src_install() {
+       save_config ${PN}.conf
+       rm ${PN}.conf || die
+       insinto /lib/firmware/
+       doins -r *
+}
+
+pkg_preinst() {
+       if use savedconfig; then
+               ewarn "USE=savedconfig is active. You must handle file collisions manually."
+       fi
+}
+
+pkg_postinst() {
+       elog "If you are only interested in particular firmware files, edit the saved"
+       elog "configfile and remove those that you do not want."
+}