net-mail/dovecot: Fix DoublePrefixInPath
authorMichał Górny <mgorny@gentoo.org>
Thu, 29 Aug 2019 05:25:14 +0000 (07:25 +0200)
committerMichał Górny <mgorny@gentoo.org>
Thu, 29 Aug 2019 10:05:39 +0000 (12:05 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
net-mail/dovecot/dovecot-2.2.36.4.ebuild
net-mail/dovecot/dovecot-2.3.6.ebuild
net-mail/dovecot/dovecot-2.3.7.1.ebuild
net-mail/dovecot/dovecot-2.3.7.2.ebuild

index b55489b6a0177a9f7cd73c7d75acae361aba350c..ddcf00b21ae26699b483dfe83d78451f1ae452b6 100644 (file)
@@ -160,8 +160,8 @@ src_install () {
        # better:
        if use suid;then
                einfo "Changing perms to allow deliver to be suided"
-               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
-               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
        fi
 
        newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
@@ -187,7 +187,7 @@ src_install () {
        doins doc/example-config/*.{conf,ext}
        insinto /etc/dovecot/conf.d
        doins doc/example-config/conf.d/*.{conf,ext}
-       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
        rm -f "${confd}/../README"
 
        # .maildir is the Gentoo default
index a37dbd5f911fa24fc7beaa7dcf88ae8a73102ef0..7abeccbbadd293141745bb30b0f04063f48de935 100644 (file)
@@ -167,8 +167,8 @@ src_install () {
        # better:
        if use suid;then
                einfo "Changing perms to allow deliver to be suided"
-               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
-               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
        fi
 
        newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
@@ -194,7 +194,7 @@ src_install () {
        doins doc/example-config/*.{conf,ext}
        insinto /etc/dovecot/conf.d
        doins doc/example-config/conf.d/*.{conf,ext}
-       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
        rm -f "${confd}/../README"
 
        # .maildir is the Gentoo default
index 9ca01af7c7fa2734f5f919b217cde32e33875ad9..89f0139e20b6784d4ca8f542ce8d0d35d0426e9a 100644 (file)
@@ -164,8 +164,8 @@ src_install () {
        # better:
        if use suid;then
                einfo "Changing perms to allow deliver to be suided"
-               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
-               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
        fi
 
        newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
@@ -191,7 +191,7 @@ src_install () {
        doins doc/example-config/*.{conf,ext}
        insinto /etc/dovecot/conf.d
        doins doc/example-config/conf.d/*.{conf,ext}
-       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
        rm -f "${confd}/../README"
 
        # .maildir is the Gentoo default
index 38e14dd4818ca16b8e862fac44da7ba4917028b3..f94d4cf9aacdeb3aa6b008c1665d034a31f11b9d 100644 (file)
@@ -164,8 +164,8 @@ src_install () {
        # better:
        if use suid;then
                einfo "Changing perms to allow deliver to be suided"
-               fowners root:mail "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
-               fperms 4750 "${EPREFIX}/usr/libexec/dovecot/dovecot-lda"
+               fowners root:mail "/usr/libexec/dovecot/dovecot-lda"
+               fperms 4750 "/usr/libexec/dovecot/dovecot-lda"
        fi
 
        newinitd "${FILESDIR}"/dovecot.init-r6 dovecot
@@ -191,7 +191,7 @@ src_install () {
        doins doc/example-config/*.{conf,ext}
        insinto /etc/dovecot/conf.d
        doins doc/example-config/conf.d/*.{conf,ext}
-       fperms 0600 "${EPREFIX}"/etc/dovecot/dovecot-{ldap,sql}.conf.ext
+       fperms 0600 /etc/dovecot/dovecot-{ldap,sql}.conf.ext
        rm -f "${confd}/../README"
 
        # .maildir is the Gentoo default