dev-util/hfstospell: gcc-10 fix
authorJoonas Niilola <juippis@gentoo.org>
Mon, 11 May 2020 17:11:07 +0000 (20:11 +0300)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 11 May 2020 17:12:16 +0000 (20:12 +0300)
Closes: https://bugs.gentoo.org/721894
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch [new file with mode: 0644]
dev-util/hfstospell/hfstospell-0.5.1.ebuild

diff --git a/dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch b/dev-util/hfstospell/files/hfstospell-0.5.1-gcc-10-fix.patch
new file mode 100644 (file)
index 0000000..0998bee
--- /dev/null
@@ -0,0 +1,24 @@
+From a9d5afb14aa71893f142dfd3ae735e8930aa0f8a Mon Sep 17 00:00:00 2001
+From: Martin Liska <mliska@suse.cz>
+Date: Mon, 16 Mar 2020 11:32:10 +0100
+Subject: [PATCH] Fix a typo in wide string conversion function (#49).
+
+Revert a hunk from:
+04e4843e4c66beb61b756f3ceb2ac94628142185.
+---
+ main.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/main.cc b/main.cc
+index abecf46..e4fd676 100644
+--- a/main.cc
++++ b/main.cc
+@@ -61,7 +61,7 @@ static bool suggest_reals = false;
+ #ifdef WINDOWS
+ static std::string wide_string_to_string(const std::wstring & wstr)
+ {
+-  int size_needed = WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)§wstr.size(), NULL, 0, NULL, NULL);
++  int size_needed = WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)wstr.size(), NULL, 0, NULL, NULL);
+   std::string str( size_needed, 0 );
+   WideCharToMultiByte(CP_UTF8, 0, &wstr[0], (int)wstr.size(), &str[0], size_needed, NULL, NULL);
+   return str;
index 84452334ab9feb3bd0a00c58e8c7c7a07b69f026..bf47865439b9fd5e0b422d3ac102af85dbc4f6d0 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -22,6 +22,8 @@ BDEPEND="virtual/pkgconfig"
 
 S="${WORKDIR}/hfst-ospell-${PV}"
 
+PATCHES=( "${FILESDIR}/hfstospell-0.5.1-gcc-10-fix.patch" )
+
 src_prepare() {
        default
        eautoreconf