Fix building with GCC 4.1 and overhaul ebuild.
authorRyan Hill <rhill@gentoo.org>
Sun, 28 Jan 2007 05:03:36 +0000 (05:03 +0000)
committerRyan Hill <rhill@gentoo.org>
Sun, 28 Jan 2007 05:03:36 +0000 (05:03 +0000)
Package-Manager: portage-2.1.2-r4

net-irc/vyqchat/ChangeLog
net-irc/vyqchat/files/digest-vyqchat-0.1.1
net-irc/vyqchat/files/digest-vyqchat-0.2.6
net-irc/vyqchat/files/digest-vyqchat-0.2.8 [new file with mode: 0644]
net-irc/vyqchat/files/vyqchat-0.2.8-gcc41.patch [new file with mode: 0644]
net-irc/vyqchat/vyqchat-0.2.8.ebuild [new file with mode: 0644]

index db5cce854c9201a5dfeb01c0468bbf5a61d56fc4..49d6d43d23ad27af245a55d41b6079a07e46d666 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-irc/vyqchat
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/ChangeLog,v 1.11 2005/07/07 04:53:45 caleb Exp $
+# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/ChangeLog,v 1.12 2007/01/28 05:03:36 dirtyepic Exp $
+
+*vyqchat-0.2.8 (28 Jan 2007)
+
+  28 Jan 2007; Ryan Hill <dirtyepic@gentoo.org>
+  +files/vyqchat-0.2.8-gcc41.patch, +vyqchat-0.2.8.ebuild:
+  Fix building with GCC 4.1 and overhaul ebuild.
 
   07 Jul 2005; Caleb Tennis <caleb@gentoo.org> vyqchat-0.1.1.ebuild,
   vyqchat-0.2.3.ebuild, vyqchat-0.2.6.ebuild:
index 51724e475961e113dd0e9f44fa8dc3622e3da74f..d3668e4263559fe6d465a63fad21a4d2435345f5 100644 (file)
@@ -1 +1,3 @@
 MD5 f28b5698f82e3723ecf346439b8cf632 vyqchat-0.1.1.tar.gz 231689
+RMD160 f375c1b01941520579219b584f663686b26098b4 vyqchat-0.1.1.tar.gz 231689
+SHA256 d51787305c7981ddb6a937d0ea6103a762ba108f80011b4a6d66574ad7881a6d vyqchat-0.1.1.tar.gz 231689
index e0c0c7c1feeb5807b8a220273155779e2b6dd7f9..0b0e33a220ce4ee8f48f214e92491c096f39fc25 100644 (file)
@@ -1,2 +1,6 @@
-MD5 a512eafdfe25ad4e3dfb81a67b0d986f vyqchat-0.2.6.tar.gz 239369
 MD5 b3f741d23b3aad6a004c67df3c6ab80b vyqchat-0.2.6-fix.tar.gz 57370
+RMD160 40a69fbf99148c9a6995095f1836eaecc09f65bb vyqchat-0.2.6-fix.tar.gz 57370
+SHA256 7b3076997dc8b480ce1034f1db272f20cd21cc4860c681cf9238e4582eb8b8d6 vyqchat-0.2.6-fix.tar.gz 57370
+MD5 a512eafdfe25ad4e3dfb81a67b0d986f vyqchat-0.2.6.tar.gz 239369
+RMD160 006797b13324094b5387ca5b1e84202736c9abd0 vyqchat-0.2.6.tar.gz 239369
+SHA256 07583c6b716226a67aabde959a8eb98ee6a38df6f69620b373ab8718890eae94 vyqchat-0.2.6.tar.gz 239369
diff --git a/net-irc/vyqchat/files/digest-vyqchat-0.2.8 b/net-irc/vyqchat/files/digest-vyqchat-0.2.8
new file mode 100644 (file)
index 0000000..6f13cdb
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 67974bc5df1ed0d63785d04325444d4f vyqchat-0.2.8.tar.gz 413505
+RMD160 6882af689d43fe20b617a95acf3e3f9caab84e3b vyqchat-0.2.8.tar.gz 413505
+SHA256 d05e9d720977c73a187bb69f54135d638f54d60e9ede6ba01e853c6930c0c234 vyqchat-0.2.8.tar.gz 413505
diff --git a/net-irc/vyqchat/files/vyqchat-0.2.8-gcc41.patch b/net-irc/vyqchat/files/vyqchat-0.2.8-gcc41.patch
new file mode 100644 (file)
index 0000000..64f903a
--- /dev/null
@@ -0,0 +1,36 @@
+diff -Naur vyqchat-0.2.8-orig/src/settings.h vyqchat-0.2.8/src/settings.h
+--- vyqchat-0.2.8-orig/src/settings.h  2006-10-29 22:47:48.000000000 -0600
++++ vyqchat-0.2.8/src/settings.h       2006-10-29 22:50:13.000000000 -0600
+@@ -88,7 +88,7 @@
+               //
+               // Get methods
+-              const UUID& Settings::getUUID()    const { return uuid; }
++              const UUID& getUUID()              const { return uuid; }
+               const QString& getIconThemeName()  const { return icontheme; }
+               const QString& getNick()           const { return nick; }
+               char getGender()                   const { return gender; }
+diff -Naur vyqchat-0.2.8-orig/src/sound.h vyqchat-0.2.8/src/sound.h
+--- vyqchat-0.2.8-orig/src/sound.h     2006-10-29 22:47:48.000000000 -0600
++++ vyqchat-0.2.8/src/sound.h  2006-10-29 22:49:32.000000000 -0600
+@@ -47,7 +47,7 @@
+               bool reload_samples(Settings &settings);
+               static bool init(Settings *settings);
+               static void close();
+-              static const QString& Sound::error();
++              static const QString& error();
+               static void play(VyEvent evt);
+ };
+diff -Naur vyqchat-0.2.8-orig/src/user.h vyqchat-0.2.8/src/user.h
+--- vyqchat-0.2.8-orig/src/user.h      2006-10-29 22:47:48.000000000 -0600
++++ vyqchat-0.2.8/src/user.h   2006-10-29 22:49:12.000000000 -0600
+@@ -38,7 +38,7 @@
+                       }
+                       return false;
+               }
+-              bool User::setStatus(char s) { status=s; return true; }
++              bool setStatus(char s) { status=s; return true; }
+               void setNick(const QString &nick) { setText(nick); }
+               int incDeadCounter() { if (dcnt<1) dcnt++; return dcnt; }
+               int decDeadCounter() { return --dcnt; }
diff --git a/net-irc/vyqchat/vyqchat-0.2.8.ebuild b/net-irc/vyqchat/vyqchat-0.2.8.ebuild
new file mode 100644 (file)
index 0000000..ac8a589
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/vyqchat/vyqchat-0.2.8.ebuild,v 1.1 2007/01/28 05:03:36 dirtyepic Exp $
+
+inherit eutils
+
+DESCRIPTION="QT based Vypress Chat clone for X."
+HOMEPAGE="http://linux.bydg.org/~yogin/"
+SRC_URI="http://linux.bydg.org/~yogin/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc"
+
+IUSE="arts"
+
+DEPEND="=x11-libs/qt-3*
+       arts? ( media-libs/libsndfile
+               media-libs/libao
+               kde-base/arts )"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+       unpack ${A}
+       cd "${S}"
+
+       epatch "${FILESDIR}"/${P}-gcc41.patch
+}
+
+src_compile() {
+       econf \
+               --with-x \
+               --with-Qt-dir=/usr/qt/3 \
+               $(use_with arts) \
+               $(use_with arts sndfile) \
+               $(use_with arts libao) \
+               || die "econf failed"
+
+       emake || die "make failed"
+}
+
+src_install() {
+       emake DESTDIR="${D}" install || die "make install failed"
+       dodoc ChangeLog FAQ NEWS PROTOCOL README README-KEYS \
+               THANKS TODO || die "dodoc failed"
+}