dev-python/lit: Control lit job count
authorMichał Górny <mgorny@gentoo.org>
Thu, 8 Mar 2018 21:57:28 +0000 (22:57 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 8 Mar 2018 22:18:52 +0000 (23:18 +0100)
Closes: https://bugs.gentoo.org/649554

dev-python/lit/lit-6.0.9999.ebuild
dev-python/lit/lit-9999.ebuild

index f167a14c32b7e24dd05ee9810feaafb835605414..d3e98d7342bd0aaef5d4c170b0ca87861df45a57 100644 (file)
@@ -4,7 +4,7 @@
 EAPI=6
 
 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 git-r3 multiprocessing
 
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
@@ -36,5 +36,6 @@ src_unpack() {
 }
 
 python_test() {
-       ./lit.py -vv tests || die
+       ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+               -vv tests || die
 }
index 43d292abf1deb8a28f03488ac68da8037cd74231..74471d6212c76d1f8e18971cefbc0fad069b3e78 100644 (file)
@@ -1,10 +1,10 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
 
 PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-inherit distutils-r1 git-r3
+inherit distutils-r1 git-r3 multiprocessing
 
 DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
 HOMEPAGE="https://llvm.org/"
@@ -35,5 +35,6 @@ src_unpack() {
 }
 
 python_test() {
-       ./lit.py -vv tests || die
+       ./lit.py -j "${LIT_JOBS:-$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")}" \
+               -vv tests || die
 }