sys-libs/newlib: bump up to 3.1.0, bug #656018
authorSergei Trofimovich <slyfox@gentoo.org>
Wed, 23 Oct 2019 06:47:35 +0000 (07:47 +0100)
committerSergei Trofimovich <slyfox@gentoo.org>
Wed, 23 Oct 2019 06:48:45 +0000 (07:48 +0100)
Reported-by: David Flogeras
Closes: https://bugs.gentoo.org/656018
Package-Manager: Portage-2.3.76, Repoman-2.3.17
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-libs/newlib/Manifest
sys-libs/newlib/newlib-3.1.0.ebuild [new file with mode: 0644]
sys-libs/newlib/newlib-9999.ebuild

index 8685b42c85a80c4da8ca55fd8e166fb0e3c86ea9..53910d65b6f51540989d3ca666b64e03a3b58cc6 100644 (file)
@@ -5,3 +5,4 @@ DIST newlib-2.2.0.tar.gz 16521910 BLAKE2B 530290c8f219774885e3c408889b7f58bbeefe
 DIST newlib-2.3.0.20160104.tar.gz 17674117 BLAKE2B abdfd902e502da32862d8151bf11bd778548cc930bcd2e0e546f5b23c075d6448f3f85e7b4388d64fbf255a5f3b893ace6e13405115a7dc0e3ac5c8846722429 SHA512 d83ce298b1b72eabf92e4ec14af3afdf3122e34aff5e320295a398df077235a78aa87148895b441a4f7de3047815e7ce13ea06a06135dd86b69a200236514293
 DIST newlib-2.4.0.tar.gz 17574364 BLAKE2B d97be2fe2fe93629230a2b0b1dbf23b2062fab54921e658bae9438fb42a1af975d763f2643352b5dbc3027faffa76ff97170aed9f5d6fb33ae4c6d947f1b608b SHA512 c60665e793dce2368a5baf23560beb50f641e1831854d702d1d7629fb6e9200cf814527f29796792a3d2dff81afee4255723df99ceb0732f99dd9580a17d2ac0
 DIST newlib-2.5.0.tar.gz 17912392 BLAKE2B bc89491758d59f3529c72308e963c5b3e39044d6d586ef3814cc19cf55aee33948656c544df7dfcbe3915105e7373f53d7b2baf96b9b8147e3af780c1d08e670 SHA512 4c99e8dfcb4a7ad0769b9e173ff06628d82e4993ef87d3adf9d6b5578626b14de81b4b3c5f0673ddbb49dc9f3d3628f9f8d4432dcded91f5cd3d27b7d44343cd
+DIST newlib-3.1.0.tar.gz 17958952 BLAKE2B 3a84ae81fc07e442a4ed3da7a78e7ede34cc7e24b5d1c66a12624ed808e5f85f134751fcea0e4ce9eb39df287a582821f751a8610a088c149895b5e38eb06989 SHA512 efc4c3ab7153387780d141386bca5d3e20c9d25ae3e6b87cf94c8df9d301ce5926dacdff9bd33aeb9781559d933c3d0ae77f4e5b46120d90792f75dbfde702c7
diff --git a/sys-libs/newlib/newlib-3.1.0.ebuild b/sys-libs/newlib/newlib-3.1.0.ebuild
new file mode 100644 (file)
index 0000000..52ef720
--- /dev/null
@@ -0,0 +1,141 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+inherit flag-o-matic toolchain-funcs
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://sourceware.org/git/newlib-cygwin.git"
+       inherit git-r3
+else
+       SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
+       KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+fi
+
+export CBUILD=${CBUILD:-${CHOST}}
+export CTARGET=${CTARGET:-${CHOST}}
+if [[ ${CTARGET} == ${CHOST} ]] ; then
+       if [[ ${CATEGORY} == cross-* ]] ; then
+               export CTARGET=${CATEGORY#cross-}
+       fi
+fi
+
+DESCRIPTION="Newlib is a C library intended for use on embedded systems"
+HOMEPAGE="https://sourceware.org/newlib/"
+
+LICENSE="NEWLIB LIBGLOSS GPL-2"
+SLOT="0"
+IUSE="nls threads unicode headers-only nano"
+RESTRICT="strip"
+
+NEWLIBBUILD="${WORKDIR}/build"
+NEWLIBNANOBUILD="${WORKDIR}/build.nano"
+NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
+
+# Adding -U_FORTIFY_SOURCE to conter the effect of Gentoo's
+# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
+# Currently newlib can't be built itself when _FORTIFY_SOURCE
+# is set.
+CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
+CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
+
+pkg_setup() {
+       # Reject newlib-on-glibc type installs
+       if [[ ${CTARGET} == ${CHOST} ]] ; then
+               case ${CHOST} in
+                       *-newlib|*-elf) ;;
+                       *) die "Use sys-devel/crossdev to build a newlib toolchain" ;;
+               esac
+       fi
+}
+
+src_configure() {
+       # we should fix this ...
+       unset LDFLAGS
+       CHOST=${CTARGET} strip-unsupported-flags
+       CCASFLAGS_ORIG="${CCASFLAGS}"
+       CFLAGS_ORIG="${CFLAGS}"
+
+       local myconf=(
+               # Disable legacy syscall stub code in newlib.  These have been
+               # moved to libgloss for a long time now, so the code in newlib
+               # itself just gets in the way.
+               --disable-newlib-supplied-syscalls
+       )
+       [[ ${CTARGET} == "spu" ]] \
+               && myconf+=( --disable-newlib-multithread ) \
+               || myconf+=( $(use_enable threads newlib-multithread) )
+
+       mkdir -p "${NEWLIBBUILD}"
+       cd "${NEWLIBBUILD}"
+
+       export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
+       export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
+       ECONF_SOURCE=${S} \
+       econf \
+               $(use_enable unicode newlib-mb) \
+               $(use_enable nls) \
+               "${myconf[@]}"
+
+       # Build newlib-nano beside newlib (original)
+       # Based on https://tracker.debian.org/media/packages/n/newlib/rules-2.1.0%2Bgit20140818.1a8323b-2
+       if use nano ; then
+               mkdir -p "${NEWLIBNANOBUILD}" || die
+               cd "${NEWLIBNANOBUILD}" || die
+               export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
+               export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
+               ECONF_SOURCE=${S} \
+               econf \
+                       $(use_enable unicode newlib-mb) \
+                       $(use_enable nls) \
+                       --enable-newlib-reent-small \
+                       --disable-newlib-fvwrite-in-streamio \
+                       --disable-newlib-fseek-optimization \
+                       --disable-newlib-wide-orient \
+                       --enable-newlib-nano-malloc \
+                       --disable-newlib-unbuf-stream-opt \
+                       --enable-lite-exit \
+                       --enable-newlib-global-atexit \
+                       --enable-newlib-nano-formatted-io \
+                       ${myconf}
+       fi
+}
+
+src_compile() {
+       export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_FULL}"
+       export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_FULL}"
+       emake -C "${NEWLIBBUILD}"
+
+       if use nano ; then
+               export "CFLAGS_FOR_TARGET=${CFLAGS_ORIG} ${CFLAGS_NANO}"
+               export "CCASFLAGS=${CCASFLAGS_ORIG} ${CFLAGS_NANO}"
+               emake -C "${NEWLIBNANOBUILD}"
+       fi
+}
+
+src_install() {
+       cd "${NEWLIBBUILD}" || die
+       emake -j1 DESTDIR="${D}" install
+
+       if use nano ; then
+               cd "${NEWLIBNANOBUILD}" || die
+               emake -j1 DESTDIR="${NEWLIBNANOTMPINSTALL}" install
+               # Rename nano lib* files to lib*_nano and move to the real ${D}
+               local nanolibfiles=""
+               nanolibfiles=$(find "${NEWLIBNANOTMPINSTALL}" -regex ".*/lib\(c\|g\|rdimon\)\.a" -print)
+               for f in ${nanolibfiles}; do
+                       local l="${f##${NEWLIBNANOTMPINSTALL}}"
+                       mv -v "${f}" "${D}/${l%%\.a}_nano.a" || die
+               done
+
+               # Move newlib-nano's version of newlib.h to newlib-nano/newlib.h
+               mkdir -p "${D}/usr/${CTARGET}/include/newlib-nano" || die
+               mv "${NEWLIBNANOTMPINSTALL}/usr/${CTARGET}/include/newlib.h" \
+                       "${D}/usr/${CTARGET}/include/newlib-nano/newlib.h" || die
+       fi
+
+       # minor hack to keep things clean
+       rm -rf "${D}"/usr/share/info || die
+       rm -rf "${D}"/usr/info || die
+}
index 6575c24051a7a4a92f1a66e357fcdabc5e61eddb..52ef720a87f46eb58a88b243fe0d45f8105138dc 100644 (file)
@@ -1,7 +1,7 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="6"
+EAPI="7"
 
 inherit flag-o-matic toolchain-funcs
 
@@ -10,9 +10,7 @@ if [[ ${PV} == "9999" ]] ; then
        inherit git-r3
 else
        SRC_URI="ftp://sourceware.org/pub/newlib/${P}.tar.gz"
-       if [[ ${PV} != *.201[5-9]???? ]] ; then
-               KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
-       fi
+       KEYWORDS="-* ~arm ~hppa ~m68k ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
 fi
 
 export CBUILD=${CBUILD:-${CHOST}}
@@ -35,8 +33,12 @@ NEWLIBBUILD="${WORKDIR}/build"
 NEWLIBNANOBUILD="${WORKDIR}/build.nano"
 NEWLIBNANOTMPINSTALL="${WORKDIR}/nano_tmp_install"
 
-CFLAGS_FULL="-ffunction-sections -fdata-sections"
-CFLAGS_NANO="-Os -ffunction-sections -fdata-sections"
+# Adding -U_FORTIFY_SOURCE to conter the effect of Gentoo's
+# auto-addition of _FORTIFY_SOURCE at gcc site: bug #656018#c4
+# Currently newlib can't be built itself when _FORTIFY_SOURCE
+# is set.
+CFLAGS_FULL="-ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
+CFLAGS_NANO="-Os -ffunction-sections -fdata-sections -U_FORTIFY_SOURCE"
 
 pkg_setup() {
        # Reject newlib-on-glibc type installs