media-video/vdrsync: Bump to EAPI 7
authorMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 08:41:30 +0000 (09:41 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sun, 10 Nov 2019 08:53:03 +0000 (09:53 +0100)
Closes: https://bugs.gentoo.org/697262
Signed-off-by: Michał Górny <mgorny@gentoo.org>
media-video/vdrsync/files/vdrsync-0.1.3_pre050322-path.diff
media-video/vdrsync/vdrsync-0.1.3_pre050322-r1.ebuild

index 768665be62a86adb9664f682362b7064f38b220e..3babee396dfa17419f607dc23c90f212909cb2b5 100644 (file)
@@ -2,8 +2,8 @@ fix not founded path to some progs
 
 Joerg Bornkessel <hd_brummy@gentoo.org> ( 29 May 2005 )
 
---- vdrsync.pl.orig    2006-05-29 19:10:25.146198500 +0200
-+++ vdrsync.pl 2006-05-29 19:09:06.937310750 +0200
+--- a/vdrsync.pl       2006-05-29 19:10:25.146198500 +0200
++++ b/vdrsync.pl       2006-05-29 19:09:06.937310750 +0200
 @@ -37,19 +37,19 @@
  # Hash that lists potential helper Programs
  #########################################################################
index fb37db3df2e3e546a6590b9dc3827c25d38eb001..c6248cefd7b61223bd3d87a7b9816213bcabe14a 100644 (file)
@@ -1,17 +1,14 @@
 # Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI=0
-
-inherit eutils
+EAPI=7
 
 MY_P="${PN}-${PV#*_pre}"
 
-S=${WORKDIR}/vdrsync-${MY_SNAPSHOT}
-
 DESCRIPTION="converting vdr-recordings to mpeg2, dvd or other similar formats"
 HOMEPAGE="http://vdrsync.vdr-portal.de/"
 SRC_URI="http://vdrsync.vdr-portal.de/releases/${MY_P}.tgz"
+S=${WORKDIR}/${MY_P}
 
 SLOT="0"
 LICENSE="GPL-2"
@@ -20,30 +17,22 @@ IUSE="dvdr"
 
 DEPEND=""
 RDEPEND=">=dev-lang/perl-5.8.0
-               media-fonts/corefonts
-               dvdr? (
-                       >=media-libs/gd-2.0.15
-                       >=dev-perl/GD-2.0.7
-                       >=dev-perl/GDTextUtil-0.86
-                       >=media-video/dvdauthor-0.6.8
-               )"
+       media-fonts/corefonts
+       dvdr? (
+               >=media-libs/gd-2.0.15
+               >=dev-perl/GD-2.0.7
+               >=dev-perl/GDTextUtil-0.86
+               >=media-video/dvdauthor-0.6.8
+       )"
 
 S=${WORKDIR}/${MY_P}
 
-src_unpack() {
-       unpack ${A}
-
-       cd "${S}"
+src_prepare() {
+       default
        sed -e "s:/usr/X11R6/lib/X11/fonts/truetype/arial.ttf:/usr/share/fonts/corefonts/arial.ttf:g" \
-               -i dvd-menu.pl
-
-       epatch "${FILESDIR}/${P}-path.diff"
+               -i dvd-menu.pl || die
+       eapply "${FILESDIR}/${P}-path.diff"
 }
-# vdrsync/dvd-menu use hardcoded tmp-directory for large (up to and
-# greater than 1G). Uncomment and change the next two lines to your
-# needs if you need another tmp-Dir
-#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/dvd-menu.pl
-#sed -e 's:"/tmp/":"/temp/":g' /usr/bin/vdrsync.pl
 
 src_install() {
        dobin check-vdrsync.pl vdrsync.pl vdrsync_buffer.pl