dev-perl/App-CLI: Bump to version 0.500.0
authorKent Fredric <kentnl@gentoo.org>
Sun, 19 Aug 2018 07:50:08 +0000 (19:50 +1200)
committerKent Fredric <kentnl@gentoo.org>
Sun, 19 Aug 2018 07:50:22 +0000 (19:50 +1200)
- EAPI6
- Enable parallel tests
- Nuke upstream author tests

Upstream:
- Migrate away from Module::Install
- Improve documentation
- Fix subcommand() to support old genre
- Add commands() and files() routines
- Add more tests
- Add a default version command
- Add a "commands" command to list commands in app
- Improve brief_usage() output

Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-perl/App-CLI/App-CLI-0.500.0.ebuild [new file with mode: 0644]
dev-perl/App-CLI/Manifest
dev-perl/App-CLI/files/App-CLI-0.50-authortests.patch [new file with mode: 0644]
dev-perl/App-CLI/metadata.xml

diff --git a/dev-perl/App-CLI/App-CLI-0.500.0.ebuild b/dev-perl/App-CLI/App-CLI-0.500.0.ebuild
new file mode 100644 (file)
index 0000000..9f65047
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=PTC
+DIST_VERSION=0.50
+inherit perl-module
+
+DESCRIPTION="Dispatcher module for command line interface programs"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="test"
+
+PATCHES=("${FILESDIR}/${PN}-0.50-authortests.patch")
+PERL_RM_FILES=(
+       "t/03-pod.t"
+       "t/99-kwalitee.t"
+)
+
+RDEPEND="
+       dev-perl/Capture-Tiny
+       virtual/perl-Carp
+       dev-perl/Class-Load
+       >=virtual/perl-Getopt-Long-2.350.0
+       virtual/perl-Locale-Maketext-Simple
+       virtual/perl-Pod-Simple
+       virtual/perl-Scalar-List-Utils
+"
+DEPEND="${RDEPEND}
+       virtual/perl-ExtUtils-MakeMaker
+       test? (
+               virtual/perl-Test-Simple
+       )
+"
index 21b8d9c4a3530a04bb2669b530e00f403e93e9e0..fbed7502f91b88c87113f2781cd94861a3da76c0 100644 (file)
@@ -1 +1,2 @@
 DIST App-CLI-0.313.tar.gz 30225 BLAKE2B 4fc19e437fc986ec69fbae7b45527e0c78528a71eaeaa437dbfb1d60200bac06903ebc10e2ad44cefffedd0a9fd18d58e9007fe5669c0f85e57fad4f3f118fdf SHA512 5c0a3780467f4c2f4f0ff9bce800f4de30643fdf9c48799cc459237f97d7ed93a01832b8b0cbdfa333fefe7e2cd8a53d36e9feb18874cbc8e5bf130923a600c8
+DIST App-CLI-0.50.tar.gz 15624 BLAKE2B 8411c8234101347a9a45a01e1cf61ddcacfeba5b24704f104f90ff021bc568b5ce9c46eca3cdddbf712a47a335d86346bf32e664d09d86dcd84ceca63469f178 SHA512 177e1a7b4724b7369df28a235c268ce5ac5103b3973995f68afd20ac6b2d37640049837624f472b29ea2eed9ec736bf25ae97af34a9dcd28b90b293e0139a572
diff --git a/dev-perl/App-CLI/files/App-CLI-0.50-authortests.patch b/dev-perl/App-CLI/files/App-CLI-0.50-authortests.patch
new file mode 100644 (file)
index 0000000..6e8aba9
--- /dev/null
@@ -0,0 +1,78 @@
+From 34d1795db568385cfcde4287768fa498e5e080fa Mon Sep 17 00:00:00 2001
+From: Kent Fredric <kentnl@gentoo.org>
+Date: Sun, 19 Aug 2018 19:38:10 +1200
+Subject: Kill unwanted author tests and their deps
+
+---
+ MANIFEST        |  2 --
+ META.json       |  3 ---
+ META.yml        |  3 ---
+ Makefile.PL     |  3 ---
+ t/03-pod.t      | 13 -------------
+ t/99-kwalitee.t | 17 -----------------
+ 6 files changed, 41 deletions(-)
+ delete mode 100644 t/03-pod.t
+ delete mode 100644 t/99-kwalitee.t
+
+diff --git a/MANIFEST b/MANIFEST
+index f9edd45..4f20438 100644
+--- a/MANIFEST
++++ b/MANIFEST
+@@ -12,8 +12,6 @@ MANIFEST.SKIP
+ README.md
+ t/01-basic.t
+ t/02-command.t
+-t/03-pod.t
+-t/99-kwalitee.t
+ t/lib/CLITest.pm
+ t/lib/MyApp.pm
+ t/lib/MyApp/Help.pm
+diff --git a/META.json b/META.json
+index db0951a..7ce6d07 100644
+--- a/META.json
++++ b/META.json
+@@ -53,10 +53,7 @@
+       },
+       "test" : {
+          "requires" : {
+-            "Class::Load" : "0",
+-            "Test::Kwalitee" : "0",
+             "Test::More" : "0",
+-            "Test::Pod" : "0",
+             "lib" : "0"
+          }
+       }
+diff --git a/META.yml b/META.yml
+index 774bfb0..9b9efee 100644
+--- a/META.yml
++++ b/META.yml
+@@ -6,11 +6,8 @@ author:
+   - 'Shelling       <navyblueshellingford@gmail.com>'
+   - 'Paul Cochrane  <paul@liekut.de>'
+ build_requires:
+-  Class::Load: '0'
+   ExtUtils::MakeMaker: '0'
+-  Test::Kwalitee: '0'
+   Test::More: '0'
+-  Test::Pod: '0'
+   lib: '0'
+ configure_requires:
+   ExtUtils::MakeMaker: '0'
+diff --git a/Makefile.PL b/Makefile.PL
+index f5039b8..eaa4a72 100644
+--- a/Makefile.PL
++++ b/Makefile.PL
+@@ -34,10 +34,7 @@ WriteMakefile(
+     MIN_PERL_VERSION => 5.006,
+     TEST_REQUIRES    => {
+         'lib'            => 0,
+-        'Class::Load'    => 0,
+-        'Test::Kwalitee' => 0,
+         'Test::More'     => 0,
+-        'Test::Pod'      => 0,
+     },
+     META_MERGE => {
+         "meta-spec" => { version => 2 },
+-- 
+2.17.1
+
index b081f217eb3d56ee294ff9b89e42867262c31c3b..3a6b3f5c165177e19bf98842e36370280c960e8b 100644 (file)
@@ -9,7 +9,9 @@
     <remote-id type="cpan">App-CLI</remote-id>
     <remote-id type="cpan-module">App::CLI</remote-id>
     <remote-id type="cpan-module">App::CLI::Command</remote-id>
+    <remote-id type="cpan-module">App::CLI::Command::Commands</remote-id>
     <remote-id type="cpan-module">App::CLI::Command::Help</remote-id>
+    <remote-id type="cpan-module">App::CLI::Command::Version</remote-id>
     <remote-id type="cpan-module">App::CLI::Helper</remote-id>
   </upstream>
 </pkgmetadata>