x11-plugins/wmnetload: EAPI bump, fix compilation with new libdockapp
authorBernard Cafarelli <voyageur@gentoo.org>
Sun, 23 Aug 2015 20:34:49 +0000 (22:34 +0200)
committerBernard Cafarelli <voyageur@gentoo.org>
Sun, 23 Aug 2015 20:35:02 +0000 (22:35 +0200)
Package-Manager: portage-2.2.20.1

x11-plugins/wmnetload/files/wmnetload-1.3-r4-configure.patch [new file with mode: 0644]
x11-plugins/wmnetload/wmnetload-1.3-r3.ebuild
x11-plugins/wmnetload/wmnetload-1.3-r4.ebuild [new file with mode: 0644]

diff --git a/x11-plugins/wmnetload/files/wmnetload-1.3-r4-configure.patch b/x11-plugins/wmnetload/files/wmnetload-1.3-r4-configure.patch
new file mode 100644 (file)
index 0000000..3b26aca
Binary files /dev/null and b/x11-plugins/wmnetload/files/wmnetload-1.3-r4-configure.patch differ
index a1884858490f9a3de3d2c5dc45fabdae2db41912..325c93098bde80de48939c15b5a36b4a89117a4f 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -13,7 +13,7 @@ SLOT="0"
 KEYWORDS="amd64 ppc ppc64 x86"
 IUSE=""
 
-RDEPEND=">=x11-libs/libdockapp-0.6.1"
+RDEPEND="<x11-libs/libdockapp-0.7"
 
 src_unpack() {
        unpack ${A}
diff --git a/x11-plugins/wmnetload/wmnetload-1.3-r4.ebuild b/x11-plugins/wmnetload/wmnetload-1.3-r4.ebuild
new file mode 100644 (file)
index 0000000..c6bdb64
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="Network interface monitor dockapp"
+HOMEPAGE="http://freshmeat.net/projects/wmnetload/"
+SRC_URI="ftp://truffula.com/pub/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=">=x11-libs/libdockapp-0.7:="
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+       epatch "${FILESDIR}/${PN}-${PVR}-configure.patch"
+       sed -e 's#<dockapp.h>#<libdockapp/dockapp.h>#' -i src/*.c || die
+
+       eautoreconf
+}
+
+src_install() {
+       emake DESTDIR="${D}" install
+       dodoc AUTHORS README NEWS
+}