media-plugins/kodi-game-libretro-bnes: 0.83.0.3 version bump
authorCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:09:08 +0000 (17:09 -0400)
committerCraig Andrews <candrews@gentoo.org>
Tue, 2 Jul 2019 21:16:30 +0000 (17:16 -0400)
Bug: https://bugs.gentoo.org/688474
Package-Manager: Portage-2.3.68, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
media-plugins/kodi-game-libretro-bnes/Manifest [new file with mode: 0644]
media-plugins/kodi-game-libretro-bnes/kodi-game-libretro-bnes-0.83.0.3.ebuild [new file with mode: 0644]
media-plugins/kodi-game-libretro-bnes/kodi-game-libretro-bnes-9999.ebuild

diff --git a/media-plugins/kodi-game-libretro-bnes/Manifest b/media-plugins/kodi-game-libretro-bnes/Manifest
new file mode 100644 (file)
index 0000000..276e2a9
--- /dev/null
@@ -0,0 +1 @@
+DIST kodi-game-libretro-bnes-0.83.0.3.tar.gz 809447 BLAKE2B 4efcc72c60ceb433f755afe39058cffc2c39f9ad3726bd407b832b39fc4e4eb85287f6fc25cdbbebfe1b21db4b567fcd260544c1de544ddff2a94ab190c643d8 SHA512 371830f91cf3f7f47b45cd86ec7438a697e0acf886881e87c6dc9218d599e983cac0a540065b6d45b9228b20dd2c1bc264345ee454b55f68d13c62e33944bfd4
diff --git a/media-plugins/kodi-game-libretro-bnes/kodi-game-libretro-bnes-0.83.0.3.ebuild b/media-plugins/kodi-game-libretro-bnes/kodi-game-libretro-bnes-0.83.0.3.ebuild
new file mode 100644 (file)
index 0000000..960b86f
--- /dev/null
@@ -0,0 +1,38 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils kodi-addon
+
+DESCRIPTION="bNES GameClient for Kodi"
+HOMEPAGE="https://github.com/kodi-game/game.libretro.bnes"
+SRC_URI=""
+
+if [[ ${PV} == *9999 ]]; then
+       SRC_URI=""
+       EGIT_REPO_URI="https://github.com/kodi-game/game.libretro.bnes.git"
+       inherit git-r3
+else
+       KEYWORDS="~amd64 ~x86"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.bnes/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.bnes-${PV}-${CODENAME}"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="
+       =media-tv/kodi-18*
+       games-emulation/libretro-bnes
+       "
+RDEPEND="
+       media-plugins/kodi-game-libretro
+       ${DEPEND}
+       "
+src_prepare() {
+       echo 'find_library(BNES_LIB NAMES bnes_libretro${CMAKE_SHARED_LIBRARY_SUFFIX} PATH_SUFFIXES libretro)' > "${S}/Findlibretro-bnes.cmake" || die
+       default
+}
index 75ecc68d0df21be420005fa076304e7588f95d26..bdef35c1c5174f11487d61f0dc88a1095a1d4f82 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
@@ -15,8 +15,9 @@ if [[ ${PV} == *9999 ]]; then
        inherit git-r3
 else
        KEYWORDS="~amd64 ~x86"
-       SRC_URI="https://github.com/kodi-game/game.libretro.bnes/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-       S="${WORKDIR}/game.libretro.bnes-${PV}"
+       CODENAME="Leia"
+       SRC_URI="https://github.com/kodi-game/game.libretro.bnes/archive/${PV}-${CODENAME}.tar.gz -> ${P}.tar.gz"
+       S="${WORKDIR}/game.libretro.bnes-${PV}-${CODENAME}"
 fi
 
 LICENSE="GPL-2"