fix bug 162353 and remove old version
authorSimon Stelling <blubb@gentoo.org>
Tue, 16 Jan 2007 14:05:26 +0000 (14:05 +0000)
committerSimon Stelling <blubb@gentoo.org>
Tue, 16 Jan 2007 14:05:26 +0000 (14:05 +0000)
Package-Manager: portage-2.1.2_rc4-r6

app-emulation/x86-chroot/ChangeLog
app-emulation/x86-chroot/files/initd
app-emulation/x86-chroot/files/x86-chroot

index c86a8b11c1d7ff47427297ea2e3f1f29198d4413..3bd6c3a6cb1aa17e6d71ec82b6e728e696ed06c7 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for app-emulation/x86-chroot
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.4 2006/10/04 08:57:08 blubb Exp $
+# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-emulation/x86-chroot/ChangeLog,v 1.5 2007/01/16 14:05:26 blubb Exp $
+
+  16 Jan 2007; <blubb@gentoo.org> files/initd, files/x86-chroot,
+  -x86-chroot-2006.0.ebuild:
+  fix bug 162353 and remove old version
 
   04 Oct 2006; Simon Stelling <blubb@gentoo.org> x86-chroot-2006.1.ebuild:
   tweak make.conf for bug 150022
index 084447a474fc4d56033fdf73adbb22a40542c185..0bd9bb1d52eadad4651a3a1abe39258e00556ded 100644 (file)
@@ -15,7 +15,7 @@ start() {
            mount -o bind ${loc} ${CHROOT_LOCATION}${loc} >/dev/null
        done
        eval "$(portageq envvar -v PORTDIR DISTDIR)"
-       [[ -d ${PORTDIR}/distfiles ]] || mkdir ${PORTDIR}/distfiles
+       [[ -d ${CHROOT_LOCATION}/usr/portage/distfiles ]] || mkdir -p ${CHROOT_LOCATION}/usr/portage/distfiles
        mount -o bind ${PORTDIR} ${CHROOT_LOCATION}/usr/portage >/dev/null
        mount -o bind ${DISTDIR} ${CHROOT_LOCATION}/usr/portage/distfiles >/dev/null
        eend $? "An error occured while attempting to mount 32bit chroot directories"
@@ -25,7 +25,6 @@ start() {
                [[ -f /etc/${conffile} ]] && cp -pf /etc/${conffile} ${CHROOT_LOCATION}/etc >/dev/null &
        done
        cp -Ppf /etc/localtime ${CHROOT_LOCATION}/etc >/dev/null &
-       which xhost &>/dev/null && xhost local:localhost &>/dev/null
        eend $? "An error occured while attempting to copy 32 bits chroot files."
 }
 
index 966c4dac086fe1490e02afd4e6ce2f3bcd2c400d..6233c243d91d693e2416a5b448e9c5ca3abb14ff 100644 (file)
@@ -1,3 +1,4 @@
 #!/bin/bash
 source /etc/conf.d/x86-chroot
+which xhost &>/dev/null && xhost local:localhost &>/dev/null
 linux32 chroot ${CHROOT_LOCATION} /bin/bash