ros-meta/simulators: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 13:01:30 +0000 (15:01 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Wed, 23 Sep 2015 13:02:35 +0000 (15:02 +0200)
Package-Manager: portage-2.2.21

ros-meta/simulators/Manifest [new file with mode: 0644]
ros-meta/simulators/metadata.xml [new file with mode: 0644]
ros-meta/simulators/simulators-1.2.0.ebuild [new file with mode: 0644]
ros-meta/simulators/simulators-9999.ebuild [new file with mode: 0644]

diff --git a/ros-meta/simulators/Manifest b/ros-meta/simulators/Manifest
new file mode 100644 (file)
index 0000000..7ebda7a
--- /dev/null
@@ -0,0 +1 @@
+DIST metapackages-1.2.0.tar.gz 1803 SHA256 02360aefee1a3ec8506cb475be00a053827d422fed26d123764b4d6b18b0a5c5 SHA512 a004a1323c93e191b98a4fe665409fb57396fb06c19e9205817f2467e171bfba10a86713978e13739632e04f148b476e582c6f1fd3c859b4936980923f204e80 WHIRLPOOL 1bb4a73678613dd6fe6b0d1225b3fd967fbb476e5736949846f3297febf727f41c9d3e71565b13dcc90d36d57a6cf012a3cdad509ed4364bb87de7e372c69a79
diff --git a/ros-meta/simulators/metadata.xml b/ros-meta/simulators/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/ros-meta/simulators/simulators-1.2.0.ebuild b/ros-meta/simulators/simulators-1.2.0.ebuild
new file mode 100644 (file)
index 0000000..2e1ed55
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for ROS simulation packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       ros-meta/robot
+       ros-meta/gazebo_ros_pkgs
+       ros-meta/rqt_common_plugins
+       ros-meta/rqt_robot_plugins
+       dev-ros/stage_ros
+"
+DEPEND="${RDEPEND}"
diff --git a/ros-meta/simulators/simulators-9999.ebuild b/ros-meta/simulators/simulators-9999.ebuild
new file mode 100644 (file)
index 0000000..2e1ed55
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+ROS_REPO_URI="https://github.com/ros/metapackages"
+KEYWORDS="~amd64"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Metapackage for ROS simulation packages"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       ros-meta/robot
+       ros-meta/gazebo_ros_pkgs
+       ros-meta/rqt_common_plugins
+       ros-meta/rqt_robot_plugins
+       dev-ros/stage_ros
+"
+DEPEND="${RDEPEND}"