dev-util/intel-graphics-compiler: bump to 1.0.3826
authorMarek Szuba <marecki@gentoo.org>
Sun, 26 Apr 2020 20:55:01 +0000 (21:55 +0100)
committerMarek Szuba <marecki@gentoo.org>
Sun, 26 Apr 2020 21:24:49 +0000 (22:24 +0100)
Moreover, src_configure() now explicitly appends -DNDEBUG to CPPFLAGS -
since commit 95577dd5076a8e9864e82879fd3af97cf63fcfe9 cmake.eclass
doesn't do it any more and in IGC this definition does considerably more
than just disable asserts.

Bug: https://bugs.gentoo.org/718824
Signed-off-by: Marek Szuba <marecki@gentoo.org>
dev-util/intel-graphics-compiler/Manifest
dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3826.ebuild [new file with mode: 0644]

index 53a203e919ac33d3f3301f2e9656aac6f9bf73d9..c2c875d3605cea849abad9dcdfc64c071151dadf 100644 (file)
@@ -1,2 +1,3 @@
 DIST intel-graphics-compiler-1.0.3151.tar.gz 5950502 BLAKE2B 8ccbfc5d3cd6307eb5db602822d42e8744e6ca7696494a0dd349847aff0defde2434b9192f17645f1fcbf732ec98a66dbdcc7d03eed48702d90911f912135fc1 SHA512 a6e04a3a90aae9046f2698bf15d5f60862c93e7a87a6e4ae6b6c43c65490583608f201e94a2ef32fc2f72e9fa0da7d6c202f64ef610f03a81384ac537541df14
 DIST intel-graphics-compiler-1.0.3445.tar.gz 6026437 BLAKE2B 4a4708109d125891dfe967186efbc2ebe70ce59dc0302f534dad74c0b1f2af36de0d7ee7cb69059e776ab4669236f5d62750159a44d44a6444ab85a205273563 SHA512 044b941adb921b25a1ab6da3ebe0f7c4d67769b43e5b855ae94871281cf387ce45351b8b46a6e98e3bd573022d7cfd9316629d590327c8f4007e1b1ae9f7071e
+DIST intel-graphics-compiler-1.0.3826.tar.gz 6007014 BLAKE2B fc09d6443818403bca803f3f78fbb9ee9a25ab674372585b880e038227712f8114ca2b17d6b219149f54f9f5856b973d3500f6537027660d1c657d61992f9e9b SHA512 e4f06d6b8d2a7161f80956a8e9cbf23aa7293a31781405bc17ee512d27ca4114facc6bb0fa7f47fde3a37aa79ce288a98aef8b74c4e572e73d70bb50c21f6fbb
diff --git a/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3826.ebuild b/dev-util/intel-graphics-compiler/intel-graphics-compiler-1.0.3826.ebuild
new file mode 100644 (file)
index 0000000..ecb0377
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+CMAKE_ECLASS=cmake
+
+inherit cmake-multilib flag-o-matic llvm
+
+DESCRIPTION="LLVM-based OpenCL compiler targetting Intel Gen graphics hardware"
+HOMEPAGE="https://github.com/intel/intel-graphics-compiler"
+SRC_URI="https://github.com/intel/${PN}/archive/igc-${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+LLVM_MAX_SLOT=9
+
+COMMON="<=sys-devel/llvm-${LLVM_MAX_SLOT}.9999:=[${MULTILIB_USEDEP}]
+       <=dev-libs/opencl-clang-${LLVM_MAX_SLOT}.9999:=[${MULTILIB_USEDEP}]"
+DEPEND="${COMMON}"
+RDEPEND="${COMMON}"
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.0.9-no_Werror.patch
+)
+
+S="${WORKDIR}"/${PN}-igc-${PV}
+
+multilib_src_configure() {
+       # Select the same slot as the best opencl-clang
+       local ocl_clang_ver="$(best_version -d dev-libs/opencl-clang:=)"
+       einfo "Selecting $ocl_clang_ver"
+       local llvm_slot=$(ver_cut 5 $ocl_clang_ver)
+       # opencl-clang brings the right slot as dep
+       has_version -d sys-devel/llvm:$llvm_slot || die "LLVM slot matching $ocl_clang_ver not found ($llvm_slot)"
+       einfo "Selecting LLVM SLOT $llvm_slot: $(best_version -d sys-devel/llvm:$llvm_slot)"
+
+       # Since late March 2020 cmake.eclass does not set -DNDEBUG any more, and the way
+       # IGC uses this definition causes problems for some users (see Bug #718824).
+       use debug || append-cppflags -DNDEBUG
+
+       local mycmakeargs=(
+               -DCMAKE_LIBRARY_PATH=$(get_llvm_prefix ${llvm_slot})/$(get_libdir)
+               -DIGC_OPTION__FORCE_SYSTEM_LLVM=ON
+               -DIGC_PREFERRED_LLVM_VERSION=${llvm_slot}
+       )
+       cmake_src_configure
+}