net-misc/asterisk-g729: version bump post asterisk-16.
authorJaco Kroon <jaco@uls.co.za>
Wed, 8 Apr 2020 06:27:37 +0000 (08:27 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Mon, 13 Apr 2020 07:41:30 +0000 (10:41 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Jaco Kroon <jaco@uls.co.za>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-misc/asterisk-g729/Manifest
net-misc/asterisk-g729/asterisk-g729-16.0.3.1.9.ebuild [new file with mode: 0644]

index f138f2d5d37220f37c88a05415b82f719fb9c406..e675b5caa0aebcf6a2f59ae5850cf628f62b1c5e 100644 (file)
@@ -6,3 +6,5 @@ DIST codec_g729a-11.0_3.1.9-x86_32.tar.gz 411132 BLAKE2B 6325763e27c25ab101ec825
 DIST codec_g729a-11.0_3.1.9-x86_64.tar.gz 478377 BLAKE2B 409cdd436b0cf11c8d68372b1b22f29ed6e2d9f01d77ca8494415c29e89e88472c126461e9d124661dbd4ef26725301cbc3bb859884ae02592ad583a37608896 SHA512 f97972e4afac2897162cfce7c49423a36d313801246238e3923993e04a2add020028a509c11cb1f4f39ec612c4243007fe564438cf82e1c71543a44bf0bbd2c8
 DIST codec_g729a-13.0_3.1.9-x86_32.tar.gz 411156 BLAKE2B 179c77d32d1f8ac3314813a1d2ce51cee1cb7b9c1b9f5e8e78c4ed1169c0719f893c55c4fe890fb657196a37c5a4779164924a8696817ba7bbe6f17146286b82 SHA512 9b064b3db3c40f900b88937efde1605dfb67316d92adc3774b4e3322e9bc5042e6670a2d385b6487a8980620eb92c8564b4fd3535810bab117f53b2762e8ca68
 DIST codec_g729a-13.0_3.1.9-x86_64.tar.gz 478364 BLAKE2B 49136479e1bd139fcb22130868575d5be7d6784081307679cfeee16951f6a303b5328a62c23a0ade506f2df0527b275bd198560dacd59ba5b9ba237095622778 SHA512 5fa2dca977ca1dcbf3019fc86c3edc91fd561c814bfa9a5202680b7a581f03faa1705a4392a70409f9cd30a4379691b609f0f572030972cbe432cad435314951
+DIST codec_g729a-16.0_3.1.9-x86_32.tar.gz 476772 BLAKE2B e1a7b8baefc551f16618fded2663acfb825a7eabcccc7ca844792e6179bac5b9ac2e0f4c387e3b2861347c6deb5db13f41ecd265c2261dbb65756890d976f4f7 SHA512 cddf46f369b0922a5569961688fcd4fb840bcce3a5573549d8a3a3e6150e20cd7c18e32ea07edc10150dd409763504ab50fad5d884fb33a49d624e4ebe0afd10
+DIST codec_g729a-16.0_3.1.9-x86_64.tar.gz 475819 BLAKE2B d738dccb1e94ae5458b72de7f52d3bb9964f3be993efe44f615bc06b0c17638ac743dd0465a68c172f339d888ceac35b54babadd217c13b028575c3b1e5aa94b SHA512 f6c60c66fce03ea5ce02301dc9c8b5a93fefbc60089980401cd1fee58357b2c03ab2b12eb50df82d2f3a25613e37c1bb370a319cf0a36c92983ef98aa137429d
diff --git a/net-misc/asterisk-g729/asterisk-g729-16.0.3.1.9.ebuild b/net-misc/asterisk-g729/asterisk-g729-16.0.3.1.9.ebuild
new file mode 100644 (file)
index 0000000..317b549
--- /dev/null
@@ -0,0 +1,67 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+DESCRIPTION="G.729 codec and supporting files for asterisk"
+HOMEPAGE="https://www.sangoma.com/asterisk/software/g729-codec/"
+
+AST_PV="$(ver_cut 1-2)"
+MY_PV="$(ver_rs 2 _)"
+
+SRC_URI="x86? (
+       https://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-32/codec_g729a-${MY_PV}-x86_32.tar.gz
+       https://downloads.digium.com/pub/register/x86-32/register -> astregister-x86_32
+       https://downloads.digium.com/pub/register/x86-32/asthostid -> asthostid-x86_32
+)
+amd64? (
+       https://downloads.digium.com/pub/telephony/codec_g729/asterisk-${AST_PV}/x86-64/codec_g729a-${MY_PV}-x86_64.tar.gz
+       https://downloads.digium.com/pub/register/x86-64/register -> astregister-x86_64
+       https://downloads.digium.com/pub/register/x86-64/asthostid -> asthostid-x86_64
+)"
+
+LICENSE="Digium"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="=net-misc/asterisk-$(ver_cut 1)*"
+
+RESTRICT="mirror strip"
+
+S="${WORKDIR}"
+
+pkg_setup() {
+       QA_FLAGS_IGNORED="/usr/$(get_libdir)/asterisk/modules/codec_g729a.so"
+       QA_PREBUILT="/usr/sbin/asthostid
+               /usr/sbin/astregister"
+}
+
+src_unpack() {
+       local dfile
+
+       for dfile in ${A}; do
+               [[ "${dfile}" = *.tar.gz ]] && unpack "${dfile}"
+               cp "${DISTDIR}/${dfile}" "${WORKDIR}/" || die "Error copying ${dfile} to ${WORKDIR}"
+       done
+}
+
+src_install() {
+       local binsuffix
+
+       if use x86; then
+               binsuffix=x86_32
+       elif use amd64; then
+               binsuffix=x86_64
+       fi
+
+       newsbin astregister-${binsuffix} astregister
+       newsbin asthostid-${binsuffix} asthostid
+
+       dodoc codec_g729a-${MY_PV}-${binsuffix}/README
+       insinto usr/$(get_libdir)/asterisk/modules/
+       doins "codec_g729a-${MY_PV}-${binsuffix}/codec_g729a.so"
+}
+
+pkg_postinst() {
+       einfo "Please note that Digium's register utility has been installed as astregister"
+}