dev-util/conf2struct: Disable parallel make
authorCraig Andrews <candrews@gentoo.org>
Fri, 19 Jul 2019 15:20:49 +0000 (11:20 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 19 Jul 2019 15:47:09 +0000 (11:47 -0400)
Closes: https://bugs.gentoo.org/690152
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Craig Andrews <candrews@gentoo.org>
dev-util/conf2struct/conf2struct-0_pre0.ebuild

index 67441e8cca93aecfb2810a03378d6d449dd4e699..33d18ebd06e372bfc21aceffa9f4b71ed76644fc 100644 (file)
@@ -33,6 +33,11 @@ RDEPEND="dev-libs/libconfig
        dev-perl/Conf-Libconfig"
 DEPEND="${RDEPEND}"
 
+src_compile(){
+       # -j1 due to parallel make issue reported upstream at: https://github.com/yrutschle/conf2struct/issues/10
+       emake -j1
+}
+
 src_install(){
        emake DESTDIR="${D}" prefix="${EPREFIX%/}/usr" install
 }