dev-python/parso: Bump to 0.5.1
authorMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 06:07:42 +0000 (08:07 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 14 Jul 2019 06:23:01 +0000 (08:23 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/parso/Manifest
dev-python/parso/parso-0.5.1.ebuild [new file with mode: 0644]

index 0ac76f4241ded0b2cb791ecd4b9d72e0ba1eb733..31618dcb1b463c32b5c7d34d6b0bc9b64f3217a1 100644 (file)
@@ -1,2 +1,3 @@
 DIST parso-0.3.1.tar.gz 375226 BLAKE2B 71481f5f382f14e5f2c7826f8eb50a1c35f8c280f14c8bf52bcf44f77aa9872cddce7d7fb7b0a586ab7cda547e43bbce11812077ae84129c418a9f0bb3c5b856 SHA512 f83e316a41e21d3132d9ee8a45f9042962c01a2b906e8791046112b9ed938d378b0dc28c4ae05ce03a8c2d19563a49cba9a9a230654345ff62e87cc763536ddb
 DIST parso-0.5.0.tar.gz 386652 BLAKE2B f12e34aa9b93a1d3eedca96588148ac1e9ecb3a6af3910627d251e2281df285ce8768c11bf3cac35f8a977f0dac2f7a906fb20171db35fae2bec1c60cd0d7dc6 SHA512 cd2a38e538faf4faf3f1828f4e69dfe685ef1fd3e120326ca5260f0edbc23952e51ffd8370a2bb2de513a90ecde76e6ea2fe76d84d3ab4115c7817e3af08e701
+DIST parso-0.5.1.tar.gz 388060 BLAKE2B 429ab40501d38e982cf77e0dbbfa4d8677dd1e2400945436b8eced608a41015b7028f586cf9af6057e441765f0a1db519a642ceadaba14620a92f452ce709871 SHA512 a04ef9bbe156bc28ac9fa64d091d3f1dcc9cf4b15a3c109cd33de1c4d34d0bf741016b88b6c12d456e953253942b7d522e0b793c9a00e9fb06de27ab0667c7fc
diff --git a/dev-python/parso/parso-0.5.1.ebuild b/dev-python/parso/parso-0.5.1.ebuild
new file mode 100644 (file)
index 0000000..9c33ffe
--- /dev/null
@@ -0,0 +1,35 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="a python parser that supports error recovery and round-trip parsing"
+HOMEPAGE="https://github.com/davidhalter/parso https://pypi.org/project/parso/"
+SRC_URI="https://github.com/davidhalter/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+
+DEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       doc? ( dev-python/sphinx )
+       test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+       py.test -vv test || die "tests failed with ${EPYTHON}"
+}
+
+python_compile_all() {
+       use doc && emake -C docs html
+}
+
+python_install_all() {
+       use doc && HTML_DOCS=( "${S}"/docs/_build/html/. )
+       distutils-r1_python_install_all
+}