dev-python/algopy: Remove python3
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 20:52:30 +0000 (21:52 +0100)
committerMichał Górny <mgorny@gentoo.org>
Tue, 28 Jan 2020 21:30:10 +0000 (22:30 +0100)
This package has only one revdep that's py2-only, and it is unlikely
to be ever used anywhere else.

Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/algopy/algopy-0.5.3.ebuild

index 819d381dbcc0f2fa934de4efd80d7541e5013981..4deca4ef6ad9bc0165b41f8eba13bf53e35f80da 100644 (file)
@@ -3,7 +3,7 @@
 
 EAPI=6
 
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1
 
@@ -18,8 +18,14 @@ IUSE="test"
 RESTRICT="!test? ( test )"
 
 RDEPEND="
-       dev-python/numpy[${PYTHON_USEDEP}]
-       sci-libs/scipy[${PYTHON_USEDEP}]
+       || (
+               dev-python/numpy-python2[${PYTHON_USEDEP}]
+               dev-python/numpy[${PYTHON_USEDEP}]
+       )
+       || (
+               sci-libs/scipy-python2[${PYTHON_USEDEP}]
+               sci-libs/scipy[${PYTHON_USEDEP}]
+       )
 "
 DEPEND="${RDEPEND}
        test? ( dev-python/nose[${PYTHON_USEDEP}] )