dev-util/scons: Bump to 3.0.4
authorMichał Górny <mgorny@gentoo.org>
Thu, 24 Jan 2019 07:33:14 +0000 (08:33 +0100)
committerMichał Górny <mgorny@gentoo.org>
Thu, 24 Jan 2019 07:38:34 +0000 (08:38 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-util/scons/Manifest
dev-util/scons/scons-3.0.4.ebuild [new file with mode: 0644]

index 8f4d46b2920f2fbcec36b992fc2f5faa074b0827..6a0fef99ce75eb306394650169496099d04a4c1c 100644 (file)
@@ -9,3 +9,7 @@ DIST scons-3.0.3-user.html 1131439 BLAKE2B d1755cd462f7e6aad51c6289bd3137c0ae67f
 DIST scons-3.0.3-user.pdf 2545890 BLAKE2B c68c173e62c4a42e01d87f749556ebe1ce4b6f2c3e96e8b87825aefac30b59ad9642977c35441172e1453ffbee1812a383d7bfc24112e4562f5f24a1defc6ae2 SHA512 75da4a0870c9ef860ad1789f9a229b94affe35efd228c450d842a88090279dcfd9ae93b05df366a3d43da27c2e44ee36ae702013b9d4fe2e78db895a7892f182
 DIST scons-3.0.3.gh.tar.gz 5497106 BLAKE2B 5bf6b2eaf59200b8eeb19eeb9f4ceda6b9b6bf32561f220565617dc08c9094687ec5200eeb2e182f89d01647d5d6638d0ac742a4bd297cb4f781578707f63a83 SHA512 594c1c4c48a3c48418e2b3945fe17af96ff29d435704e8b6cbb85406cd38109d0b865cb2f7bbbc733f69ea5e0f283f4b5942a0140dac263725968e62d0c87a2e
 DIST scons-3.0.3.tar.gz 651374 BLAKE2B e095affdcdf75203559f6e1c9a94ec4ab29c5d8e84354d1ed04bd4b64f7cb14ca1916ed576eb0d180c4e871878b98072e923dd84ce5b8e61ce7fb5ab3747773b SHA512 a9f52bca2f5d98f9ec3aa6ce0fd05660d573e6738daef2162306c95f19bd95851bd83f44cab4a81187c051491b0f016137e443f70d764149bb00ad03f46f273e
+DIST scons-3.0.4-user.html 1127751 BLAKE2B 5bafa81d075c063cc8c0c4d147fdf7573834e7b0af9099b7b68d7cf3c8872061b7ecc93e7119723eaa9d393e4463744a9e9bd8074ce28d8b518d366a11e4a215 SHA512 f3bc5591b90fb05420b00a110d32921394b867255b3925fab97420b864579702a956237983fb5b0a25d2f6d0268493b0f1819fbcb6f1027cc10ad7b59e2836a3
+DIST scons-3.0.4-user.pdf 2561758 BLAKE2B aefd100912345f399e52d805bc2f01846f0bcdfb31524212e69fb41713c193a233a30dcea9133e35001a145ce62b84c648b6d57856c0d5dfa019974546cb4d82 SHA512 03b9e1e8b60ca07986956f1e5c63d56573222ea303bed1976167239b4e9ad73056776a80c7fe2529987aa90856c35bc1c858d1a445f34e7964b675e700845e71
+DIST scons-3.0.4.gh.tar.gz 5500498 BLAKE2B 2157141d70f0f6d80606a0d53e0b6b99f72ac6d5f8b63e8825c1f484eb5c92979b50e897d2aadc2b201ee6f06a0d1df00ab272b96cc303c34f75124123f40a90 SHA512 d57924f0e7713ec2e5d7159fbf0078947aa5ce49f7cdf7a4ea47c19efbce7ec335a5e5448e200240be1095655c5c25f1466285f0bed5bdadeb2673845b23c4f5
+DIST scons-3.0.4.tar.gz 652334 BLAKE2B 742909dcc598780c7ca7884c2403d9fa0cab44228c6597975157148f460dadf789d3c6aaa36125815ea8fc5ba70538ede56542cbecc656c2918341e2827657b3 SHA512 064a604939460fa85aa247776e5a2083ce98cac5f49f6035886d207f5cf167255756ee10cc00dd8228278d0d1efbed2afd8793bf3ca736a3ac970fabc3c4b627
diff --git a/dev-util/scons/scons-3.0.4.ebuild b/dev-util/scons/scons-3.0.4.ebuild
new file mode 100644 (file)
index 0000000..7ba0a5a
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Extensible Python-based build utility"
+HOMEPAGE="http://www.scons.org/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+       doc? (
+               http://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+               http://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html
+       )
+       test? ( https://github.com/scons/scons/archive/${PV}.tar.gz -> ${P}.gh.tar.gz )"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x64-cygwin ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+S=${WORKDIR}/${P}/src
+
+PATCHES=(
+       # support env passthrough for Gentoo ebuilds
+       "${FILESDIR}"/scons-3.0.1-env-passthrough.patch
+       # respect CC, CXX, C*FLAGS, LDFLAGS by default
+       "${FILESDIR}"/scons-3.0.3-respect-cc-etc-r1.patch
+)
+
+src_unpack() {
+       # use the git directory structure, but put pregenerated release
+       # inside src/ subdirectory to make our life easier
+       if use test; then
+               unpack "${P}.gh.tar.gz"
+               rm -r "${P}/src" || die
+       else
+               mkdir "${P}" || die
+       fi
+
+       cd "${P}" || die
+       unpack "${P}.tar.gz"
+       mv "${P}" src || die
+}
+
+src_prepare() {
+       # apply patches relatively to top directory
+       cd "${WORKDIR}/${P}" || die
+       distutils-r1_src_prepare
+
+       # remove half-broken, useless custom commands
+       # and fix manpage install location
+       sed -i -e '/cmdclass/,/},$/d' \
+               -e '/data_files/s:man/:share/man/:' "${S}"/setup.py || die
+}
+
+python_test() {
+       cd "${WORKDIR}/${P}" || die
+       "${EPYTHON}" runtest.py -as \
+               -j "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")" \
+               --builddir "${BUILD_DIR}/lib" ||
+               die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+       local DOCS=( {CHANGES,README,RELEASE}.txt )
+       distutils-r1_python_install_all
+       rm "${ED%/}/usr/bin/scons.bat" || die
+
+       use doc && dodoc "${DISTDIR}"/${P}-user.{pdf,html}
+}