lxde-base/lxpanel: Version bump to 0.10.0
authorcharIes17 <charles17@arcor.de>
Mon, 6 May 2019 09:49:56 +0000 (11:49 +0200)
committerHanno <hanno@gentoo.org>
Tue, 7 May 2019 05:38:00 +0000 (07:38 +0200)
Closes: https://bugs.gentoo.org/681960
Closes: https://github.com/gentoo/gentoo/pull/11913
Signed-off-by: Hanno Boeck <hanno@gentoo.org>
lxde-base/lxpanel/Manifest
lxde-base/lxpanel/lxpanel-0.10.0.ebuild [new file with mode: 0644]

index 41f95a25bce2bbf61fece8c17d19ef7f40946804..832cc41949747e9dc6064c015633f9f2c051c25f 100644 (file)
@@ -1,2 +1,3 @@
+DIST lxpanel-0.10.0.tar.xz 1544700 BLAKE2B ea210feee23b2da1c9f6199bfc274c46e1142d6397ca0d1d8359329068ed6e46eaebff90fb220ce14121ed19cb5c60014230c7a7e42867318317845751418a7b SHA512 3e664eef3cf0f37cf4609f53f1f40f5d50e94ae088c497be0439851ea8f1426ef6ec1373d146e2e0ef1b9f51f557ae19eb5fb1059b0e5fcd5b1c49fd76207a59
 DIST lxpanel-0.9.2.tar.xz 1514748 BLAKE2B 31b0f949b7023364df3eb00b2386c505e14146c2b818407326347baf1dfa09b3e2e0c30c38416430c7dccad04f1fd5731a6ff80b21ea87a930492399027a056f SHA512 d7b5733345233a44466b6786133b8c3f3c9217a5195654b8dde3447a0dfc198082d991b2bc0cc60ddf200ebb95d636885b36d5642c11f4cd913f66228c12bd3a
 DIST lxpanel-0.9.3.tar.xz 1515144 BLAKE2B f069a519d0e4bd611d57a956ba585b8dde953174198d01dc264e2b111df17e2925c79bd85dc8549d7b2098147122c04ace6ed775d0a3ea7594b0b39c1f9045c0 SHA512 c6aea97f66ee1d576822fda0bf1aed3849b3c74bab856816b7d23331e48b26005f1ba12eddcc0abbf5a6f08add3cb4a0674ccd13f118cec0b6294edd6f1b2343
diff --git a/lxde-base/lxpanel/lxpanel-0.10.0.ebuild b/lxde-base/lxpanel/lxpanel-0.10.0.ebuild
new file mode 100644 (file)
index 0000000..8b084d9
--- /dev/null
@@ -0,0 +1,74 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PLOCALES="af ar be bg bn_IN bn ca cs da de el en_GB es et eu fa fi fo fr frp
+gl he hr hu id is it ja kk km ko lg lt lv ml ms nb nl nn pa pl ps pt_BR pt ro
+ru sk sl sr@latin sr sv te th tr tt_RU ug uk ur_PK ur vi zh_CN zh_HK zh_TW"
+
+PLOCALE_BACKUP="en_GB"
+
+inherit l10n readme.gentoo-r1
+
+DESCRIPTION="Lightweight X11 desktop panel for LXDE"
+HOMEPAGE="https://wiki.lxde.org/en/LXPanel"
+SRC_URI="mirror://sourceforge/lxde/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="+alsa wifi"
+
+RDEPEND="dev-libs/keybinder:0=
+       x11-libs/gtk+:2
+       >=x11-libs/libfm-1.2.0[gtk]
+       x11-libs/libwnck:1
+       x11-libs/libXmu
+       x11-libs/libXpm
+       x11-libs/cairo
+       x11-libs/gdk-pixbuf[X]
+       x11-libs/libX11
+       lxde-base/lxmenu-data
+       lxde-base/menu-cache
+       alsa? ( media-libs/alsa-lib )
+       wifi? ( net-wireless/wireless-tools )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       sys-devel/gettext"
+
+DOC_CONTENTS="If you have problems with broken icons shown in the main panel,
+you will have to configure panel settings via its menu.
+This will not be an issue with first time installations."
+
+src_prepare() {
+       default
+
+       export LINGUAS="${LINGUAS:-${PLOCALE_BACKUP}}"
+       l10n_get_locales > po/LINGUAS || die
+}
+
+src_configure() {
+       local plugins="netstatus,volume,cpu,deskno,batt, \
+               kbled,xkb,thermal,cpufreq,monitors"
+
+       use wifi && plugins+=",netstat"
+       use alsa && plugins+=",volumealsa"
+       [[ ${CHOST} == *-interix* ]] && plugins=deskno,kbled,xkb
+
+       econf $(use_enable alsa) --with-x --with-plugins="${plugins}"
+       # the gtk+ dep already pulls in libX11, so we might as well hardcode with-x
+}
+
+src_install () {
+       default
+
+       # Get rid of the .la files.
+       find "${D}" -name '*.la' -delete
+
+       readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+       readme.gentoo_print_elog
+}