dev-python/numpy: Version Bump
authorJustin Lecher <jlec@gentoo.org>
Sat, 10 Oct 2015 19:06:52 +0000 (21:06 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 11 Oct 2015 07:05:16 +0000 (09:05 +0200)
Package-Manager: portage-2.2.23
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/numpy/Manifest
dev-python/numpy/numpy-1.10.0_p2.ebuild [new file with mode: 0644]

index 330b8dd74dc4dc5562d4110c305b4a9209066e16..888858f52170a093f607cc5c53b96697591985e1 100644 (file)
@@ -1,3 +1,4 @@
+DIST numpy-1.10.0.post2.tar.gz 4082399 SHA256 2ebd29edb2f1a4a19e86cfc27c1b2283314d57509b2bfc6606b4f05d620c230b SHA512 60a4fc0ed07b8944cf7994c2fcf24eae49c659cc387d5dd5c824054fd82d9542bb07afa34a89a71bdb4a52a33b00f6eff845b611b12cf147a52308fa517730b0 WHIRLPOOL 855c6a0026c7d23d212b94beda676d191752ff22ff58305bc7a460513bfa19bc32e561ceb6d38b94065c3e7e315a7341840bf21c5ca7c748befb53af221a969a
 DIST numpy-1.8.0.tar.gz 3779617 SHA256 2764d0819acc77e9ff81b060fe7f69530b0d85c26ac9d162639b787cb227d253 SHA512 ec3d002ed786335e8748983261c96f88a9f1520fc345ad5b810dc02a5e126e15fe5afb02bed1f4b43d580a1da39583d86b84f57dc456b0702653e34e5357c857 WHIRLPOOL 8796d90795ddec62e6d72be433ea00917a63ef39cf3fe81e094f653e1863b69ecdce812995877f78e4324434141b03e2ceb3f872ed4e023b19c6bd9bcc294ac2
 DIST numpy-1.8.1.tar.gz 3794076 SHA256 3d722fc3ac922a34c50183683e828052cd9bb7e9134a95098441297d7ea1c7a9 SHA512 39ef9e13f8681a2c2ba3d74ab96fd28c5669e653308fd1549f262921814fa7c276ce6d9fb65ef135006584c608bdf3db198d43f66c9286fc7b3c79803dbc1f57 WHIRLPOOL 10615c0c70c153156034447e9c3f2b70b0259173a44af3b5cc641dd31c0af71ef1053a9cc7938deff5edb899ae2666b2b3109491d7394f03d1a81cb19722d398
 DIST numpy-1.8.2.tar.gz 3792998 SHA256 6d487fc724780d66746bde264ea71f5cd77d3a39e52ee2b073dcaed63bc669db SHA512 996e6b8e2d42f223e44660f56bf73eb8ab124f400d89218f8f5e4d7c9860ada44a4d7c54526137b0695c7a10f36e8834fbf0d42b7cb20bcdb5d5c245d673385c WHIRLPOOL 0d3a05b1e3c0a1ceb0a7b4818406dbb45506e5f25bc2727d4ff44cc0a0520e6556b3c68ae24dbca37ba9d67ae2defbb3ff9c906d4c2635b29ed44452d70e8311
diff --git a/dev-python/numpy/numpy-1.10.0_p2.ebuild b/dev-python/numpy/numpy-1.10.0_p2.ebuild
new file mode 100644 (file)
index 0000000..f7fdd3d
--- /dev/null
@@ -0,0 +1,154 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} )
+
+FORTRAN_NEEDED=lapack
+
+inherit distutils-r1 eutils flag-o-matic fortran-2 multilib multiprocessing toolchain-funcs versionator
+
+DOC_PV="1.9.1"
+DOC_P="${PN}-${DOC_PV}"
+
+DESCRIPTION="Fast array and numerical python library"
+HOMEPAGE="http://www.numpy.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P/_p/.post}.tar.gz
+       doc? (
+               http://docs.scipy.org/doc/${DOC_P}/${PN}-html-${DOC_PV}.zip
+               http://docs.scipy.org/doc/${DOC_P}/${PN}-ref-${DOC_PV}.pdf
+               http://docs.scipy.org/doc/${DOC_P}/${PN}-user-${DOC_PV}.pdf
+       )"
+# It appears the docs haven't been upgraded, still @ 1.8.1
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc lapack test"
+
+RDEPEND="
+       dev-python/setuptools[${PYTHON_USEDEP}]
+       lapack? ( virtual/cblas virtual/lapack )"
+DEPEND="${RDEPEND}
+       doc? ( app-arch/unzip )
+       lapack? ( virtual/pkgconfig )
+       test? ( >=dev-python/nose-1.0[${PYTHON_USEDEP}] )"
+
+# Uses distutils.command.config.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+       "${FILESDIR}"/${PN}-1.9.2-no-hardcode-blas.patch
+)
+
+src_unpack() {
+       default
+       mv "${WORKDIR}"/* "${S}" || die
+
+       if use doc; then
+               unzip -qo "${DISTDIR}"/${PN}-html-${DOC_PV}.zip -d html || die
+       fi
+}
+
+pc_incdir() {
+       $(tc-getPKG_CONFIG) --cflags-only-I $@ | \
+               sed -e 's/^-I//' -e 's/[ ]*-I/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libdir() {
+       $(tc-getPKG_CONFIG) --libs-only-L $@ | \
+               sed -e 's/^-L//' -e 's/[ ]*-L/:/g' -e 's/[ ]*$//' -e 's|^:||'
+}
+
+pc_libs() {
+       $(tc-getPKG_CONFIG) --libs-only-l $@ | \
+               sed -e 's/[ ]-l*\(pthread\|m\)\([ ]\|$\)//g' \
+               -e 's/^-l//' -e 's/[ ]*-l/,/g' -e 's/[ ]*$//' \
+               | tr ',' '\n' | sort -u | tr '\n' ',' | sed -e 's|,$||'
+}
+
+python_prepare_all() {
+       if use lapack; then
+               append-ldflags "$($(tc-getPKG_CONFIG) --libs-only-other cblas lapack)"
+               local libdir="${EPREFIX}"/usr/$(get_libdir)
+               # make sure _dotblas.so gets built
+               sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
+               cat >> site.cfg <<-EOF
+                       [blas]
+                       include_dirs = $(pc_incdir cblas)
+                       library_dirs = $(pc_libdir cblas blas):${libdir}
+                       blas_libs = $(pc_libs cblas blas)
+                       [lapack]
+                       library_dirs = $(pc_libdir lapack):${libdir}
+                       lapack_libs = $(pc_libs lapack)
+               EOF
+       else
+               export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
+       fi
+
+       export CC="$(tc-getCC) ${CFLAGS}"
+
+       append-flags -fno-strict-aliasing
+
+       # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
+       # with the subtle difference that we don't want to break Darwin where
+       # -shared is not a valid linker argument
+       if [[ ${CHOST} != *-darwin* ]]; then
+               append-ldflags -shared
+       fi
+
+       # only one fortran to link with:
+       # linking with cblas and lapack library will force
+       # autodetecting and linking to all available fortran compilers
+       append-fflags -fPIC
+       if use lapack; then
+               NUMPY_FCONFIG="config_fc --noopt --noarch"
+               # workaround bug 335908
+               [[ $(tc-getFC) == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
+       fi
+
+       # don't version f2py, we will handle it.
+       sed -i -e '/f2py_exe/s:+os\.path.*$::' numpy/f2py/setup.py || die
+
+       # we don't have f2py-3.3
+       sed \
+               -e "/f2py_cmd/s:'f2py'.*:'f2py':g" \
+               -i numpy/tests/test_scripts.py || die
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile() {
+       distutils-r1_python_compile -j $(makeopts_jobs) ${NUMPY_FCONFIG}
+}
+
+python_test() {
+       distutils_install_for_testing ${NUMPY_FCONFIG}
+
+       cd "${TMPDIR}" || die
+       ${EPYTHON} -c "
+import numpy, sys
+r = numpy.test(label='full', verbose=3)
+sys.exit(0 if r.wasSuccessful() else 1)" || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+       distutils-r1_python_install ${NUMPY_FCONFIG}
+}
+
+python_install_all() {
+       distutils-r1_python_install_all
+
+       dodoc COMPATIBILITY DEV_README.txt THANKS.txt
+
+       if use doc; then
+               dohtml -r "${WORKDIR}"/html/*
+               dodoc "${DISTDIR}"/${PN}-{user,ref}-${DOC_PV}.pdf
+       fi
+
+       # absent in 1.9
+       #docinto f2py
+       #dodoc numpy/f2py/docs/*.txt
+       #doman numpy/f2py/f2py.1
+}