app-admin/qtpass: bump to vn. 1.1.0
authorIan Delaney <idella4@gentoo.org>
Tue, 2 Feb 2016 06:10:08 +0000 (14:10 +0800)
committerIan Delaney <idella4@gentoo.org>
Tue, 2 Feb 2016 08:01:41 +0000 (16:01 +0800)
ebuild by maintainer sourced from the gentoo bug

Gentoo bug: #572986

Package-Manager: portage-2.2.26

app-admin/qtpass/Manifest
app-admin/qtpass/qtpass-1.1.0.ebuild [new file with mode: 0644]

index f720394d42343bdaee5df1784302f68915970718..62b807421ce8f8b599fedbacae7f98c4e15ee42d 100644 (file)
@@ -1 +1,2 @@
 DIST qtpass-1.0.5.tar.gz 636461 SHA256 0c07bd1eb9e5336c0225f891e5b9a9df103f218619cf7ec6311edf654e8db281 SHA512 e1b63f1058dc9c194f06376d52acbbb8594d429f4d7fe4ba27baed2cafe10b1c36137b3e33626c1bf33c7f3e1444e6fbe48fc66a83e0f7cd82f5b47f0193d178 WHIRLPOOL acb914d89bcd667343f648e38bb9eb316ebbf0b01f75686d3a7694e82eedd3e3f52ffc99f530bbe3ccbb6089ced727796924fcf48a94c071a3e20b27141b28df
+DIST qtpass-1.1.0.tar.gz 671525 SHA256 60b458062f54184057e55dbd9c93958a8bf845244ffd70b9cb31bf58697f0dc6 SHA512 da7439f2c18c46cbf4df15538210051ad60d036334e62a1c4f62d6c1ccff8e4327fb0c6030ed89f78ffd87b615fcaae8ed5552099ff8663bff713990216132ae WHIRLPOOL 4288ee76762c41a81fece4b72bacb1560b28d5681ce288f5e9b5fd9257fd778e4038fc0c75951bdb2a967afdf6ac66035fc716606b1ad6148834fc4ca81dfe45
diff --git a/app-admin/qtpass/qtpass-1.1.0.ebuild b/app-admin/qtpass/qtpass-1.1.0.ebuild
new file mode 100644 (file)
index 0000000..c173745
--- /dev/null
@@ -0,0 +1,62 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit qmake-utils
+
+DESCRIPTION="multi-platform GUI for pass, the standard unix password manager"
+HOMEPAGE="https://qtpass.org/"
+SRC_URI="https://github.com/IJHack/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="+qt5"
+DOCS=( FAQ.md README.md CONTRIBUTING.md )
+
+RDEPEND="qt5? (
+               dev-qt/qtcore:5
+               dev-qt/qtgui:5[xcb]
+               dev-qt/qtwidgets:5
+               dev-qt/qtnetwork:5
+       )
+       !qt5? (
+               dev-qt/qtcore:4
+               dev-qt/qtgui:4
+       )
+       app-admin/pass
+       net-misc/x11-ssh-askpass"
+DEPEND="${RDEPEND}
+       qt5? (
+               dev-qt/linguist-tools:5
+               dev-qt/qtsvg:5
+       )
+       !qt5? ( dev-qt/qtsvg:4 )"
+
+src_prepare() {
+       # Modify install path
+       sed -i "s/target.path = \$\$PREFIX/target.path = \$\$PREFIX\/bin/" \
+               ${PN}.pro \
+               || die "sed failed to modify install path for ${PN}.pro"
+
+       epatch_user
+}
+
+src_configure() {
+       if use qt5 ; then
+               eqmake5 PREFIX="${D}"/usr
+       else
+               eqmake4 PREFIX="${D}"/usr
+       fi
+}
+
+src_install() {
+       default
+
+       insinto /usr/share/applications
+       doins "${PN}.desktop"
+
+       newicon artwork/icon.svg "${PN}-icon.svg"
+}