net-proxy/trojan: version bump to 1.13.0
authorYangMame <yangmame@icloud.com>
Sun, 6 Oct 2019 01:49:52 +0000 (09:49 +0800)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 15 Dec 2019 08:20:47 +0000 (10:20 +0200)
Signed-off-by: Xin Yang <yangmame@icloud.com>
Closes: https://github.com/gentoo/gentoo/pull/13182
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-proxy/trojan/Manifest
net-proxy/trojan/trojan-1.13.0.ebuild [new file with mode: 0644]

index 8ff2ff0fa3b83fccc4c0bcc2c4ed25bed0433fe3..9aea0f4395afe5526905a10e298d54ec3aa4dfb2 100644 (file)
@@ -1,2 +1,3 @@
 DIST trojan-1.10.0.tar.gz 38230 BLAKE2B 2cfa77ebfbae62edef983d1e57e3ce00a61118f6458cab353af60960e2586750fcd0c4237631481cfdfc8ed0ddad586e1d649046269c7e9177594869c187d8d1 SHA512 9d9a74218369f8094b292b8892e5f877ccec7d8912657491bb37da8e9ae4817f07a83fe401e33bbbdd2ac9c50c1440f3a021f93d85999b43df4849b0a04049cf
 DIST trojan-1.12.3.tar.gz 41786 BLAKE2B f6306210a46316906b919fefb245a7c379ddcf785513bfbc3b8fc6a9c78e1c8cf22069533f58086fb4ffad05b625ab2b2fcacf2256520833ea49c0f307cee296 SHA512 f59afa28446dfef8680d7530aaff3609566b2873416bb11f8981ef111f63ed8deeacb2093373012547ede02dfb9beb8d92655b8f9ebafd6012c45b3ce787c22f
+DIST trojan-1.13.0.tar.gz 44579 BLAKE2B 87aba58687fa5f42385893b8d919a46428b7d3cdbd2da38ee3e96900c11a6a3df7778c2a54295d5abb1964991d2d30433c4b37e70a9ca4ba184005d338bbed74 SHA512 5904ff75d348e9ccdd451836b1b05df6736e22530643d67a192e393fe32623576e0bbc106c883b6bc32daa2a086d5a7e42f836d684b66fc0deca019b14e3b3ab
diff --git a/net-proxy/trojan/trojan-1.13.0.ebuild b/net-proxy/trojan/trojan-1.13.0.ebuild
new file mode 100644 (file)
index 0000000..02b78af
--- /dev/null
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_5,3_6,3_7} )
+
+inherit cmake-utils python-any-r1 systemd
+
+DESCRIPTION="An unidentifiable mechanism that helps you bypass GFW"
+HOMEPAGE="https://github.com/trojan-gfw/trojan"
+SRC_URI="https://github.com/trojan-gfw/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="mysql test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+       >=dev-libs/boost-1.66.0:=
+       dev-libs/openssl:0=
+       mysql? ( dev-db/mysql-connector-c:= )
+"
+DEPEND="${RDEPEND}
+       test? ( net-misc/curl ${PYTHON_DEPS} )
+"
+
+src_configure() {
+       local mycmakeargs=(
+               -DENABLE_MYSQL=$(usex mysql)
+               -DSYSTEMD_SERVICE=ON
+               -DSYSTEMD_SERVICE_PATH=$(systemd_get_systemunitdir)
+               -DCMAKE_INSTALL_DOCDIR=share/doc/${PF}
+       )
+       cmake-utils_src_configure
+}
+
+src_install() {
+       cmake-utils_src_install
+       newinitd "${FILESDIR}/trojan.initd" trojan
+}
+
+src_test() {
+       cmake-utils_src_test -j1
+}