xfce-extra/xfce4-power-manager: Bump to 1.7.0
authorMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 03:21:50 +0000 (04:21 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 6 Mar 2020 03:21:50 +0000 (04:21 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
xfce-extra/xfce4-power-manager/Manifest
xfce-extra/xfce4-power-manager/xfce4-power-manager-1.7.0.ebuild [new file with mode: 0644]

index 703a0fb56e7d7fa12cda06982a6b40040bd2aecd..bd0c32265e7d3c83a591c1200cb94f2f1457d423 100644 (file)
@@ -1 +1,2 @@
 DIST xfce4-power-manager-1.6.5.tar.bz2 1205473 BLAKE2B 64d3aa04ccb11b7b541b9ec8c3dd4544c66f8e7de626c5395cd10ea1e0004d7f3e941d9357941b73aec3997ed9935f04540d2c04ca1e6ac271baa80732de0f72 SHA512 ebcf9ba7431518fdafa74f49511200e16093c34f78516e823a2f7ac02a085a08377efe5f9c6fe285f3d1e2de253789404e01b34a48e3f5ff23c2c143b2801207
+DIST xfce4-power-manager-1.7.0.tar.bz2 1235629 BLAKE2B bf6bd6c3ebfc86d199362168788b3d9b1ca2cd691a93a2cbab04415d7e68e11a3b1cb36328e8a974e504eb00282e584cc497ea4f7dcddb20e6854d06bef5ec7d SHA512 30c6c37ce278d869b73880bc33d04115086646850c8fc9129e4fbeb71b36d4bb7ce7ee1758ea804b42b3736ec6632f7bcd8e7806a00421e0e24ac8433e34ac24
diff --git a/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.7.0.ebuild b/xfce-extra/xfce4-power-manager/xfce4-power-manager-1.7.0.ebuild
new file mode 100644 (file)
index 0000000..9df1444
--- /dev/null
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="Power manager for the Xfce desktop environment"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-power-manager"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="kernel_linux networkmanager +panel-plugin policykit"
+
+COMMON_DEPEND=">=dev-libs/glib-2.42
+       >=sys-power/upower-0.99.0
+       sys-power/pm-utils
+       >=x11-libs/gtk+-3.14:3
+       >=x11-libs/libnotify-0.7
+       x11-libs/libX11
+       >=x11-libs/libXrandr-1.2
+       x11-libs/libXext
+       x11-libs/libXtst
+       >=xfce-base/xfconf-4.12:=
+       >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+       >=xfce-base/libxfce4util-4.12:=
+       panel-plugin? ( >=xfce-base/xfce4-panel-4.12:= )
+       policykit? ( >=sys-auth/polkit-0.112 )"
+RDEPEND="${COMMON_DEPEND}
+       networkmanager? ( net-misc/networkmanager )"
+DEPEND="${COMMON_DEPEND}
+       dev-util/intltool
+       sys-devel/gettext
+       virtual/pkgconfig
+       x11-base/xorg-proto"
+
+src_configure() {
+       local myconf=(
+               $(use_enable policykit polkit)
+               $(use_enable networkmanager network-manager)
+               $(use_enable panel-plugin xfce4panel)
+       )
+
+       econf "${myconf[@]}"
+}
+
+src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}