games-util/pyfa: version bump to 2.19.0
authorAndreas Zuber <a.zuber@gmx.ch>
Tue, 7 Apr 2020 06:37:17 +0000 (08:37 +0200)
committerJoonas Niilola <juippis@gentoo.org>
Fri, 10 Apr 2020 10:30:02 +0000 (13:30 +0300)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Andreas Zuber <a.zuber@gmx.ch>
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
games-util/pyfa/Manifest
games-util/pyfa/pyfa-2.19.0.ebuild [new file with mode: 0644]

index 04af085ab2213545b71c04a42664f77c062af775..c0921874eb7ba0a0da3528c284c1d2c9cdc3f12b 100644 (file)
@@ -1,3 +1,4 @@
 DIST pyfa-2.14.1.tar.gz 14452477 BLAKE2B e4c688cff14eecaa71f86fb9e22f6a585a3136a4bd7df65c8dd65ed82c2aa9e530210134daaba25251df92dc55a7e538474b39c1d54e4bcb1817eac17791d517 SHA512 d3d3219fa37f44c81d85165c7e780261e149b47db147417ea26edaff448484ce565607aded714a4f44ca23b8c1586c8597ace856020c4c319cea6d39f353b140
 DIST pyfa-2.15.1.tar.gz 14516568 BLAKE2B ba3b1170f35681ab33bece447b4bdf563c8f964037dc6b35cbd23360f7e36c61dd9074e34b5648c7a04b59ad192f5babd75ce2a935940a52e62de8cc174f7e5b SHA512 2d8fcb8608e31c135b8dac7239afe0a5acb0d32fba1291ce6ebafe093ef232c08f0aa42d172ebac5beefb7dba47aad9eb3833c679e3d02edc9cc056739c7538b
 DIST pyfa-2.17.0.tar.gz 12348275 BLAKE2B fd670a6d34760285561ed07e82c3c54eb9a74cad732b24b89fab103fe8013608c18f27461bfac28a854df3ce7273fac1011752a8da2447b69432ad36709c08dd SHA512 d4af2c6a30deb8b205e5db55c25e1fa48dc74b964c9d85da69acca9bbd19764b77abc96ff42a2e99733d132253081a3e2c3de6ef787c162e392a9627ab62c529
+DIST pyfa-2.19.0.tar.gz 11822419 BLAKE2B 7aaa9d8fc7de7ab9fb246bdf1dd61aa4aac6035d37cc6ecf9e32b03e67baada7d3dc765d02a7d9ed75f5933ccd76f92c4ae79c822c0562f8658dd1b52dfdba4d SHA512 5083f125cfd7f5d32e76029a836089cb79c5c6c93397712d37054518ed9bd77092d0c610cecdb1d0afce40753276431cdec72699ffc04088162158b55c04bac8
diff --git a/games-util/pyfa/pyfa-2.19.0.ebuild b/games-util/pyfa/pyfa-2.19.0.ebuild
new file mode 100644 (file)
index 0000000..145ca00
--- /dev/null
@@ -0,0 +1,100 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+PYTHON_COMPAT=( python3_6 )
+PYTHON_REQ_USE="sqlite,threads"
+
+inherit desktop eutils python-single-r1 xdg-utils
+
+DESCRIPTION="Python Fitting Assistant - a ship fitting application for EVE Online"
+HOMEPAGE="https://github.com/pyfa-org/Pyfa"
+
+LICENSE="GPL-3+ all-rights-reserved"
+SLOT="0"
+if [[ ${PV} = 9999 ]]; then
+       EGIT_REPO_URI="https://github.com/pyfa-org/Pyfa.git"
+       inherit git-r3
+else
+       SRC_URI="https://github.com/pyfa-org/Pyfa/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64 ~x86"
+       S=${WORKDIR}/Pyfa-${PV}
+fi
+IUSE=""
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+RESTRICT="mirror bindist"
+
+DEPEND="
+       $(python_gen_cond_dep '
+               >=dev-python/cryptography-2.3[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/logbook-1.0.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/pyyaml-5.1[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/sqlalchemy-1.3.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/wxpython-4.0.4[webkit,${PYTHON_MULTI_USEDEP}]
+       ')
+       ${PYTHON_DEPS}"
+RDEPEND="${DEPEND}
+       $(python_gen_cond_dep '
+               >=dev-python/beautifulsoup-4.6.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/markdown2-2.3.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/packaging-16.8[${PYTHON_MULTI_USEDEP}]
+               dev-python/python-dateutil[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/requests-2.0.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/roman-2.0.0[${PYTHON_MULTI_USEDEP}]
+               >=dev-python/matplotlib-3.1.2[wxwidgets,${PYTHON_MULTI_USEDEP}]
+               dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+       ')"
+BDEPEND="app-arch/zip"
+
+PATCHES=(
+       # fix import path in the main script for systemwide installation
+       "${FILESDIR}/${PN}-2.9.3-import-pyfa.patch"
+       )
+
+src_prepare() {
+       # get rid of CRLF line endings introduced in 1.1.10 so patches work
+       edos2unix config.py pyfa.py gui/bitmap_loader.py service/settings.py
+
+       default
+
+       # make python recognize pyfa as a package
+       touch __init__.py || die
+
+       sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+               -e "s:%%EPREFIX%%:${EPREFIX}:" \
+               "${FILESDIR}/configforced-1.15.1.py" > configforced.py || die
+       sed -e "s:%%SITEDIR%%:$(python_get_sitedir):" \
+               pyfa.py > pyfa || die
+}
+
+src_install() {
+       python_moduleinto ${PN}
+       python_domodule eos gui service utils graphs
+       python_domodule config*.py __init__.py version.yml configforced.py db_update.py
+       python_doscript pyfa
+
+       insinto /usr/share/${PN}
+
+       einfo "Creating database ..."
+       python ./db_update.py || die
+       doins eve.db
+
+       einfo "Compressing images ..."
+       pushd imgs > /dev/null || die
+       zip -r imgs.zip * || die "zip failed"
+       doins imgs.zip
+       popd > /dev/null || die
+
+       dodoc README.md
+       doicon -s 32 imgs/gui/pyfa.png
+       newicon -s 64 imgs/gui/pyfa64.png pyfa.png
+       domenu "${FILESDIR}/${PN}.desktop"
+}
+
+pkg_postinst() {
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       xdg_icon_cache_update
+}