dev-python/netifaces: 0.10.6 bup
authorMatthew Thode <prometheanfire@gentoo.org>
Fri, 25 Aug 2017 20:27:36 +0000 (15:27 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Fri, 25 Aug 2017 20:27:36 +0000 (15:27 -0500)
Package-Manager: Portage-2.3.6, Repoman-2.3.3

dev-python/netifaces/Manifest
dev-python/netifaces/netifaces-0.10.6.ebuild [new file with mode: 0644]

index 9c15aa438278704b04059ac71210a4c7547ed0b8..84078836aa7dfe35e47ddcfa26cc9636bb5f448a 100644 (file)
@@ -1,2 +1,3 @@
 DIST netifaces-0.10.4.tar.gz 22969 SHA256 9656a169cb83da34d732b0eb72b39373d48774aee009a3d1272b7ea2ce109cde SHA512 1b9b92b69e01e4dd9f9304d3812d78d58ec195a657cb47b2e629ccb1311de4a8cd9716825d7b94d4791f7c479c289638780f6f9afa8a6465fb555130da622b24 WHIRLPOOL 44cb33b6ca0c6cda059bf7e88ca5b4904d1e2d5bb7201f23d8e5b9c3bd337acc99dc47dec76016b6ceee7c5d8d72af03af96afb709ff9368a8dfff8683d4b7e2
 DIST netifaces-0.10.5.tar.gz 24879 SHA256 59d8ad52dd3116fcb6635e175751b250dc783fb011adba539558bd764e5d628b SHA512 736bb985b444e78676dc10533a7597e750cadf41033196c4be49c4f33e91d46eba33a1f485e07e9f70aec2170c958564a6f54bbaa1ab193bfaca04b1fb07b3a1 WHIRLPOOL 7a0d63508dc2d2f80a4fbe4a92468696cb3335c9a47410a617de12f7c1f167a4bfc9d3a122dc666e5956b9b1422ed11f9e1839e929c85f0b0cc289eeccba4c35
+DIST netifaces-0.10.6.tar.gz 25166 SHA256 0c4da523f36d36f1ef92ee183f2512f3ceb9a9d2a45f7d19cda5a42c6689ebe0 SHA512 2c892062286007a8330c2cddc148ea21d1fd24aec32b5f25b8fe905933c651f8c532596f523f0bb7edb3a143e9a491ec49d60f75efad4407273ac2647b579b1e WHIRLPOOL 08447ff343e63417b34b2bf7a94e359865739484e46b3d02d0fc9f7d35b94d990fa5e7ee42a217b6856a2eb1adf13e82d8c0312ffbc06d47fa9d5bdea84fe244
diff --git a/dev-python/netifaces/netifaces-0.10.6.ebuild b/dev-python/netifaces/netifaces-0.10.6.ebuild
new file mode 100644 (file)
index 0000000..1062081
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Portable network interface information"
+HOMEPAGE="
+       https://pypi.python.org/pypi/netifaces/
+       http://alastairs-place.net/netifaces/
+       https://bitbucket.org/al45tair/netifaces"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+PATCHES=( "${FILESDIR}"/${PN}-0.10.4-remove-osx-fix.patch )