dev-python/snakeoil: keyword ~riscv, add python-3.7 as provider
authorAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 4 May 2019 19:19:30 +0000 (21:19 +0200)
committerAndreas K. Hüttel <dilfridge@gentoo.org>
Sat, 4 May 2019 19:20:15 +0000 (21:20 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.12
Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
dev-python/snakeoil/snakeoil-0.7.5.ebuild
dev-python/snakeoil/snakeoil-9999.ebuild

index 6dfed11edfaf0ec225af991fd37d22e5b6702eb1..fa95be1778c487c72a0eaac900afb97aed85fa67 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
 PYTHON_REQ_USE="threads(+)"
 inherit distutils-r1
 
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
        EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
        inherit git-r3
 else
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86"
+       KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~riscv s390 ~sh sparc x86"
        SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
 fi
 
index b52898dd1d354b5582ce6b09b5171a70bf03751a..e7629b6dfc9fcf4431c19b6ac97bcbf0b15f25ae 100644 (file)
@@ -10,7 +10,7 @@ if [[ ${PV} == *9999 ]] ; then
        EGIT_REPO_URI="https://github.com/pkgcore/snakeoil.git"
        inherit git-r3
 else
-       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sh ~sparc ~x86"
        SRC_URI="https://github.com/pkgcore/snakeoil/releases/download/v${PV}/${P}.tar.gz"
 fi