app-admin/puppet-agent: 6.14.0 stable amd64/x86 with cleanup
authorMatthew Thode <prometheanfire@gentoo.org>
Sat, 11 Apr 2020 17:39:58 +0000 (12:39 -0500)
committerMatthew Thode <prometheanfire@gentoo.org>
Sat, 11 Apr 2020 17:46:34 +0000 (12:46 -0500)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
app-admin/puppet-agent/Manifest
app-admin/puppet-agent/puppet-agent-6.13.0.ebuild [deleted file]
app-admin/puppet-agent/puppet-agent-6.14.0.ebuild

index 4e20fa4b6ef84bf0bf783c248282d3eefc180f45..9d68ed7de9d0a53a1af40ce5431b35c0c2145acc 100644 (file)
@@ -1,4 +1,2 @@
-DIST puppet-agent_6.13.0-1stretch_amd64.deb 22432484 BLAKE2B 231f8683afbf4d2c5ded7bfec323baecbfd52446bb3483c2c16764bc57b79a18d256ecf94b27d4db1bbe88038d7f3eef037c500a39e3b66d641e4effa94cd2d3 SHA512 6101e84e5dbfa64bd336bb23595fe559165e4a159fa5de739aa1617e6825ab11ad62d1abbee26ff94b9f68caa7a192c0339a0c721efcc534ae9ddbba161af907
-DIST puppet-agent_6.13.0-1stretch_i386.deb 22787442 BLAKE2B 1bcea00b2da5c5b0db51fdd12d3828492a9a56af3a8c84919258ac7b90f7d135df708aba602a6d517364ac8b42f1ee3f1c11596cca0e89809a72d1d04c7ecc58 SHA512 55afd1ec6d331808a2a5adcd9c41803d932bcd7e2653da42c81c8ea1179649ae7ac642993813d527b2f365fb4f21d67015a0c2eb5379de2184585475521f8726
 DIST puppet-agent_6.14.0-1stretch_amd64.deb 22450130 BLAKE2B fe6e30d99357328a884944e59d7cb1c66ad9fc36642ba377ed99e23551c5cbf06cffc4336b47440389fee7a9f1996b8325d18335768187f5d052fcecae041f5b SHA512 41d87f1ab4ead019eb5ef90ad21e557db686729151618e4ec642ea6636feda383874f7d457de7e9e323cf44d9d410e7fb650edd6e69b186c2fdff5657955ac5a
 DIST puppet-agent_6.14.0-1stretch_i386.deb 22792198 BLAKE2B 7638fd1edfeb22377ab22484dd0fd5377bab6ee5e3e01c64ffd8eae29b08e0182204446db23d8cf68018a58c2419ce22c4dda4fd10a6dfac64356d68a5478bfa SHA512 dc787dfeb2565fde00da6e991fb94435c56e804657a38268ad49d72783b9857de4e359d6d9002525759684ddcb48a00e2fdb73f069cd79da74237bcb9530a116
diff --git a/app-admin/puppet-agent/puppet-agent-6.13.0.ebuild b/app-admin/puppet-agent/puppet-agent-6.13.0.ebuild
deleted file mode 100644 (file)
index 9d360f3..0000000
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit eutils systemd unpacker
-
-DESCRIPTION="general puppet client utils along with hiera and facter"
-HOMEPAGE="https://puppetlabs.com/"
-SRC_BASE="http://apt.puppetlabs.com/pool/stretch/puppet/${PN:0:1}/${PN}/${PN}_${PV}-1stretch"
-SRC_URI="
-       amd64? ( ${SRC_BASE}_amd64.deb )
-       x86?   ( ${SRC_BASE}_i386.deb )"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="puppetdb selinux"
-RESTRICT="strip"
-
-CDEPEND="!app-admin/puppet
-       !dev-ruby/hiera
-       !dev-ruby/facter
-       !app-emulation/virt-what
-       acct-user/puppet
-       acct-group/puppet"
-
-DEPEND="
-       ${CDEPEND}
-       app-admin/augeas"
-RDEPEND="${CDEPEND}
-       app-portage/eix
-       sys-apps/dmidecode
-       sys-libs/libselinux
-       sys-libs/glibc
-       sys-libs/readline:0/7
-       sys-libs/ncurses:0[tinfo]
-       selinux? (
-               sys-libs/libselinux[ruby]
-               sec-policy/selinux-puppet
-       )
-       puppetdb? ( >=dev-ruby/puppetdb-termini-5.0.1 )"
-
-S=${WORKDIR}
-
-src_install() {
-       # conf.d
-       doconfd etc/default/puppet
-       doconfd etc/default/pxp-agent
-       # logrotate.d
-       insinto /etc/logrotate.d
-       doins etc/logrotate.d/pxp-agent
-       # puppet itself
-       insinto /etc/puppetlabs
-       doins -r etc/puppetlabs/*
-       # logdir for systemd
-       dodir var/log/puppetlabs/puppet/
-       fperms 0750 var/log/puppetlabs/puppet/
-       # the rest
-       insinto /opt
-       dodir opt/puppetlabs/puppet/cache
-       doins -r opt/*
-       fperms 0750 /opt/puppetlabs/puppet/cache
-       # init
-       newinitd "${FILESDIR}/puppet.initd" puppet
-       systemd_dounit lib/systemd/system/puppet.service
-       systemd_dounit lib/systemd/system/pxp-agent.service
-       systemd_newtmpfilesd "${FILESDIR}/puppet-agent.conf.tmpfilesd" puppet-agent.conf
-       # symlinks
-       chmod 0755 -R "${D}/opt/puppetlabs/puppet/bin/"
-       chmod 0755 "${D}//opt/puppetlabs/puppet/lib/virt-what/virt-what-cpuid-helper"
-       dosym ../../opt/puppetlabs/bin/facter /usr/bin/facter
-       dosym ../../opt/puppetlabs/bin/hiera /usr/bin/hiera
-       dosym ../../opt/puppetlabs/bin/puppet /usr/bin/puppet
-       dosym ../../opt/puppetlabs/puppet/bin/virt-what /usr/bin/virt-what
-}
index 6ef50802412924a06d128a4c71bda11b078cd141..9d360f3dc1b33ad9a4ccbe974a04245c89db5f9a 100644 (file)
@@ -13,7 +13,7 @@ SRC_URI="
 
 LICENSE="Apache-2.0"
 SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS="amd64 x86"
 IUSE="puppetdb selinux"
 RESTRICT="strip"