dev-python/python-debian: disable apt_pkg by default
authorMike Gilbert <floppym@gentoo.org>
Sun, 1 Dec 2019 04:41:44 +0000 (23:41 -0500)
committerMike Gilbert <floppym@gentoo.org>
Sun, 1 Dec 2019 04:41:44 +0000 (23:41 -0500)
Package-Manager: Portage-2.3.79_p3, Repoman-2.3.18_p2
Signed-off-by: Mike Gilbert <floppym@gentoo.org>
dev-python/python-debian/files/0.1.36-disable-apt-pkg.patch [moved from dev-python/python-debian/files/0.1.36-test-no-apt-pkg.patch with 77% similarity]
dev-python/python-debian/python-debian-0.1.36.ebuild

similarity index 77%
rename from dev-python/python-debian/files/0.1.36-test-no-apt-pkg.patch
rename to dev-python/python-debian/files/0.1.36-disable-apt-pkg.patch
index 64b040852b7d8805fe4a81245be2dd09acff8183..b497986b6dabc349a640faa5ed18dff3e41b3333 100644 (file)
@@ -1,12 +1,35 @@
-From 0b4e4e02e62ab6069e855fc44fec1cbfba3e2f2a Mon Sep 17 00:00:00 2001
+From 76b7c4e7d16e8f792323f8d14ebdb1678d9d12b0 Mon Sep 17 00:00:00 2001
 From: Mike Gilbert <floppym@gentoo.org>
 Date: Sat, 30 Nov 2019 23:18:05 -0500
-Subject: [PATCH] Remove tests that rely on apt_pkg
+Subject: [PATCH] Disable apt_pkg support
 
 ---
+ lib/debian/deb822.py            |  4 +--
  lib/debian/tests/test_deb822.py | 53 ---------------------------------
1 file changed, 53 deletions(-)
2 files changed, 2 insertions(+), 55 deletions(-)
 
+diff --git a/lib/debian/deb822.py b/lib/debian/deb822.py
+index c679f4b..2e85956 100644
+--- a/lib/debian/deb822.py
++++ b/lib/debian/deb822.py
+@@ -1913,7 +1913,7 @@ class Sources(Dsc, _PkgRelationMixin):
+     def iter_paragraphs(cls,
+                         sequence,                # type: IterableInputDataType
+                         fields=None,             # type: Optional[List[str]]
+-                        use_apt_pkg=True,        # type: bool
++                        use_apt_pkg=False,       # type: bool
+                         shared_storage=False,    # type: bool
+                         encoding="utf-8",        # type: str
+                         strict=None,             # type: Optional[Dict]
+@@ -1955,7 +1955,7 @@ class Packages(Deb822, _PkgRelationMixin, _VersionAccessorMixin):
+     def iter_paragraphs(cls,
+                         sequence,              # type: IterableInputDataType
+                         fields=None,           # type: Optional[List[str]]
+-                        use_apt_pkg=True,      # type: bool
++                        use_apt_pkg=False,     # type: bool
+                         shared_storage=False,  # type: bool
+                         encoding="utf-8",      # type: str
+                         strict=None,           # type: Optional[Dict]
 diff --git a/lib/debian/tests/test_deb822.py b/lib/debian/tests/test_deb822.py
 index 7101727..64a724c 100755
 --- a/lib/debian/tests/test_deb822.py
index 49012658cf51fc8d4b74d917d4c206f27b83946f..eb6ee829a2ec94a90841db170ec0648669093de6 100644 (file)
@@ -29,7 +29,7 @@ BDEPEND="${RDEPEND}
        )
 "
 
-PATCHES=( "${FILESDIR}/0.1.36-test-no-apt-pkg.patch" )
+PATCHES=( "${FILESDIR}/0.1.36-disable-apt-pkg.patch" )
 
 python_compile_all() {
        ${EPYTHON} lib/debian/doc-debtags > README.debtags || die