dev-python/pythonmagick: Remove Py2
authorDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:19 +0000 (17:15 +0100)
committerDavid Seifert <soap@gentoo.org>
Sat, 28 Dec 2019 16:15:19 +0000 (17:15 +0100)
Package-Manager: Portage-2.3.83, Repoman-2.3.20
Signed-off-by: David Seifert <soap@gentoo.org>
dev-python/pythonmagick/pythonmagick-0.9.17.ebuild

index 6a86f1f97d029e0651eb1a5ceaf2f27026bc7e3a..8c6684f2e4ad39f113ba476d2277c67703ea4e7a 100644 (file)
@@ -2,7 +2,7 @@
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=6
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python3_{5,6} )
 
 inherit libtool python-r1
 
@@ -37,9 +37,6 @@ src_prepare() {
 
 src_configure() {
        python_configure() {
-               if ! python_is_python3; then
-                       local -x CXXFLAGS="${CXXFLAGS} -fno-strict-aliasing"
-               fi
                econf \
                        --disable-static \
                        --with-boost-python=boost_python-${EPYTHON#python}