x11-misc/projecteur: add git to deps
authorConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 16:19:10 +0000 (18:19 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Sun, 10 May 2020 16:22:13 +0000 (18:22 +0200)
Due a bug, projecteur can't compile without having installed Git.
This is a bug and has been reported to upstream.
Meanwhile, adding Git as a temp fix to BDEPEND.

Bug: https://bugs.gentoo.org/719398
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
x11-misc/projecteur/projecteur-0.7-r1.ebuild [new file with mode: 0644]

diff --git a/x11-misc/projecteur/projecteur-0.7-r1.ebuild b/x11-misc/projecteur/projecteur-0.7-r1.ebuild
new file mode 100644 (file)
index 0000000..197f9f6
--- /dev/null
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="${PN/p/P}"
+
+inherit cmake udev xdg-utils
+
+DESCRIPTION="Linux Desktop Application for the Logitech Spotlight device"
+HOMEPAGE="https://github.com/jahnf/Projecteur"
+SRC_URI="https://github.com/jahnf/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="
+       dev-qt/qtcore:5
+       dev-qt/qtdeclarative:5
+       || (
+               dev-qt/qtgui:5[X(-)]
+               dev-qt/qtgui:5[xcb(-)]
+       )
+       dev-qt/qtnetwork:5
+       dev-qt/qtwidgets:5
+       dev-qt/qtx11extras:5
+       virtual/udev
+       x11-libs/libX11
+"
+DEPEND="${RDEPEND}"
+
+# Compilation will fail, if Git is not installed.
+# It's a bug, reported to upstream: https://github.com/jahnf/Projecteur/issues/73
+BDEPEND="
+       dev-vcs/git
+       virtual/pkgconfig
+"
+
+pkg_postinst() {
+       udev_reload
+       xdg_icon_cache_update
+}
+
+pkg_postrm() {
+       udev_reload
+       xdg_icon_cache_update
+}