net-misc/dahdi: Pass LDFLAGS="$(raw-ldflags)" to install, too (bug 447648).
authorMichael Weber <xmw@gentoo.org>
Wed, 22 Feb 2017 22:02:46 +0000 (23:02 +0100)
committerMichael Weber <xmw@gentoo.org>
Wed, 22 Feb 2017 22:02:57 +0000 (23:02 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

net-misc/dahdi/dahdi-2.11.1.ebuild

index 699e31f10a41bd2f7aa3aeb736196332a5706f55..d9cf22dde48073be2841fb11e542ce76b303d54b 100644 (file)
@@ -76,6 +76,6 @@ src_compile() {
 
 src_install() {
        einfo "Installing kernel module"
-       emake V=1 CC=$(tc-getCC) LD=$(tc-getLD) KSRC="${KV_OUT_DIR}" DESTDIR="${D}" DAHDI_MODULES_EXTRA="cwain.o qozap.o ztgsm.o" install
+       emake V=1 CC=$(tc-getCC) LD=$(tc-getLD) KSRC="${KV_OUT_DIR}" DESTDIR="${D}" DAHDI_MODULES_EXTRA="cwain.o qozap.o ztgsm.o" LDFLAGS="$(raw-ldflags)" install
        rm -rf "$D"/lib/modules/*/modules.*
 }